Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I customized a PKGBUILD for Apache, ran makepkg and installed it with pacman -U httpd.tar.xz, which worked fine. A few months later I upgraded my system with pacman -Syu which used the system-default configuration for Apache which broke my web server. How do I tell pacman to always use my custom compilation settings so I don’t have to manually upgrade every time a new version is released?

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

I solved this by installing yaourt and customizepkg, which allows me to have the best of both worlds: the latest and greatest versions from the official repositories, automatically patched to my specific needs.

share|improve this answer
add comment

Pacman won't upgrade Apache using your customized PKGBUILD; you will have to do that manually using ABS. What you can do, is prevent pacman from overwriting your customized package.

To expand on Renan's answer, if you have more than one package that you wish to prevent pacman updating, you can include a groups field in the respective PKGBUILDs and then, in /etc/pacman.conf use the IgnoreGroup line.

This gives you a little more control for multiple packages, without having to remember to edit pacman.conf as you add and remove custom PKGBUILDs.

As an example, in your PKGBUILDs, you could use:

groups=('modified')

and in /etc/pacman.conf:

IgnoreGroup = modified
share|improve this answer
add comment

You can edit /etc/pacman.conf and add the name of your package to the IgnorePkg line. That way, pacman will not touch your package upon upgrading.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.