Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My system is Gentoo amd64, and the desktop environment is Xfce4. So far, most applications works well, except the terminal and QT-family applications.

The Chromium,Thunar, Thunderbird and many other applications supports Unicode very well. I can see and input Chinese.

But the terminal does not support displaying/inputting Chinese. I tried to set the LANG and LC_CTYPE variables, set the fonts...nothing works.

My SMPlayer and VLC uses QT based UI, and both of the cannot play the video if the path/file name contains non-ASCII characters. But they works well otherwise.

share|improve this question
up vote 1 down vote accepted

It seems my problem has been solved. I mistakenly removed qt3support from my system...after I add it back, the terminal can display Chinese, and the players can play the videos correctly.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.