Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to get slitaz cooking ISO to boot using a grub2 loopback on a multiboot USB;

# /boot/grub/grub.cfg
insmod font
if loadfont /boot/grub/unicode.pf2 ; then
    insmod efi_gop
    insmod efi_uga 
    insmod gfxterm
    insmod vbe
    insmod vga
    set gfxmode=auto
    set gfxpayload=auto
    terminal_output gfxterm 
    if terminal_output gfxterm; then true ; else
        terminal gfxterm
    fi
fi

menuentry "Slitaz Cooking" {
    set isofile="/boot/slitaz-cooking.iso"
    loopback loop $isofile
    linux (loop)/boot/bzImage lang=en kmap=us isofrom=$isofile boot=live noeject noprompt root=/dev/null
    initrd (loop)/boot/rootfs.gz
}

tried with screen=text and screen=1024x768x24 kernel options but it never gets to a useable gui/terminal

share|improve this question

2 Answers 2

That entry looks correct, although I've never had to add isofrom=$isofile. I will mention that I've had the exact same problem booting from my Asus netbook, but not from other computers. And The boot froze around initramfs, not all the way at X.

I suggest you try and boot this off other computers, which would suggest we encountered the same problem.

share|improve this answer
    
just tried a different machine, displays boot process then monitor goes into powersave and machine is unresponsive ... –  Thermionix Feb 20 '12 at 2:11
up vote 0 down vote accepted
menuentry "Slitaz 3.0" {
    set isofile="/boot/slitaz-3.0.iso"
    loopback loop $isofile
    linux (loop)/boot/bzImage lang=en kmap=us autologin isofrom=$isofile boot=live noeject noprompt root=/dev/null
    initrd (loop)/boot/rootfs.gz
}

Ended up being an issue with the currently available version of cooking, downloaded the 3.0 iso and it boots fine in grub2 loopback

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.