Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

How do I make zsh give me the autcomplete options but not fill in the prompt line with the first result? For example, this is the behavior I'm seeing:

$ ifc{tab}
$ ifcfg
external command
ifcfg     ifconfig

I want it to display the options, but not fill in the prompt line.

Also, if I type in a valid command, but there are other valid commands that start with that, it doesn't auto complete. So

su{tab}

will give me just su instead of the option for sudo

share|improve this question
    
I think the default behavior conforms to your requirement. What completion options have you set? –  Gilles Oct 17 '10 at 0:54
    
I copied an zshrc file from the web and I'm wondering what options cause this to be different. I can post the zshrc file if needed –  Falmarri Oct 17 '10 at 0:59
add comment

1 Answer

up vote 1 down vote accepted
unsetopt automenu

from man zshoptions:

AUTO_MENU

Automatically use menu completion after the second consecutive request for completion, for example by pressing the tab key repeatedly. This option is overridden by MENU_COMPLETE.

share|improve this answer
    
So is it not possible to use menu_complete, but not make it fill in the text on the prompt line? –  Falmarri Oct 18 '10 at 4:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.