Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to make XTerm to never use a bold font, and nothing seems to work. I put settings in ~/.Xresources and then run xrdb ~/.Xresources and then start a new XTerm. This is what I try:

XTerm*background: gray90
XTerm*foreground: black
XTerm*highlightColor: yellow
XTerm*pointerColor: red
XTerm*pointerColorBackground: white
XTerm*cursorColor: navy
XTerm*borderColor: black

Xterm*colorBD: black
XTerm*colorBDMode: true

XTerm*boldMode: false
XTerm*alwaysBoldMode: false

XTerm*font:        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
XTerm*boldFont:    -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
XTerm*utf8Fonts.font:        -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1
XTerm*utf8Fonts.boldFont:    -misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1

And still for example when I run Midnight Commander all directory names are with thick letters, and I want them the same as normal files, just use a color, but not make them thicker! In VIM everything uses thick letters when syntax highlighting is used (but is OK - thin - when there is no syntax highlighting).

I am out of ideas, what to put in my ~/.Xresources to force XTerm to never use those thick letters?

share|improve this question

2 Answers 2

You should stick this in your ~/.Xresources file or maybe the deprecated ~/.Xdefaults file:

XTerm*allowBoldFonts:       false

You can also press Ctrl while right-clicking xterm and tick/untick the Bold Fonts option.

share|improve this answer

I can't reproduce this (I don't see any bold font when I use your settings, but this may be due to other settings of mine, I haven't looked too closely).

You may be missing a setting of XTerm*boldColors.

Note that in Xterm*colorBD: black, the class is miscapitalized (you wrote Xterm instead of XTerm).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.