Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I ran sh /media/cdrom/VBoxLinuxAdditions.run I got the following warning message:

You appear to have a version of the VBoxGuestAdditions software
on your system which was installed from a different source or using a
different type of installer.  If you installed it from a package from your
Linux distribution or if it is a default part of the system then we strongly
recommend that you cancel this installation and remove it properly before
installing this version. If this is simply and older or a damaged
installation you may safely proceed.

How do I uninstall the VBoxGuestAdditions that was a default part of Debian?


After reading and trying out jw013's answer, I suspected that maybe I just didn't know the proper package names. I did a bit more searching, and found out that I can see the list of packages installed by running dpkg -l. So I ran

dpkg -l | grep virtualbox

then I got

ii   virtualbox-ose-guest-dkms ...
ii   virtualbox-ose-guest-utils ...
ii   virtualbox-ose-guest-x11 ...

Then I removed each manually by running

apt-get remove virtualbox-ose-guest-dkms virtualbox-ose-guest-utils virtualbox-ose-guest-x11

So far it looks like that might be the solution, though it's weird because when I run the command it wants to install 38 new packages, most of them with xserver related stuff.


I tried the above with a fresh install (reasonably minimal install -- used the businesscard.iso with nothing marked when tasksel came up) then followed the directions here, and everything worked perfectly!

share|improve this question

2 Answers 2

up vote 5 down vote accepted

It's hard to tell what is going on if you can't remember or do not know where your old install of guest additions came from.

Do you have virtualbox-guest-additions installed? You can uninstall it by running (as a superuser)

apt-get remove virtualbox-guest-additions

If that's not it, I would recommend trying to follow the instructions at the VirtualBox website. Since it appears you already have an old version of the guest additions installed, try the uninstallation instructions:

sh ./VBoxLinuxAdditions.run uninstall
share|improve this answer
Is 'uninstall' supposed to be 'remove'? –  math4tots Feb 17 '12 at 7:23
@math4tots yes you are right. That's what I get for typing without thinking, doh! –  jw013 Feb 17 '12 at 7:29
I just tried it right now, and I got "Virtual packages like 'virtualbox-guest-additions' can't be removed" –  math4tots Feb 17 '12 at 7:46
I think the guest additions came with a fresh install. I set up another install of Debian with "debian-6.0.4-i386-businesscard.iso", this time with everything unchecked when tasksel came up, and I still got with GA –  math4tots Feb 17 '12 at 8:06
@math4tots hmm that's strange. It's not installed on my system, and it seems unlikely that the installer would behave differently in a VM. Did you get the latest version of guest additions installed correctly at least? –  jw013 Feb 17 '12 at 8:26

Did you try:

apt-get autoremove virtualbox-ose-guest-dkms \
        virtualbox-ose-guest-utils virtualbox-ose-guest-x11

This does remove the xorg packages though.

share|improve this answer
Autoremove should not be necessary. –  itsbruce Oct 9 '12 at 0:29
I like to remove all that isn't used/dependencies:) –  Christopher Thorjussen Nov 16 '12 at 11:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.