Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I finally was able to install Debian on my powerpc, but the only way to get a GUI up is by disabling nouveau. I just use Linux nouveau.modeset=0 at the yaboot prompt. However my color is all messed up like it's been washed in tie-dye.

I'm guessing I need to configure an xorg.conf to get the card to work? I have no idea what settings to put in there. Using an Nvidia GeForce 5200 FX with 64mb vram on a MAC G5.

share|improve this question

2 Answers 2

Adding boot parameters to force different display modes may help. I've been able to get Fedora Core 17 up on my powermac g5 by forcing the display to use the DVI-I-2 interface and disabling the rest.

http://www.mintppc.org/forums/viewtopic.php?p=5497#p5497

share|improve this answer

If nouveau is not working, you cannot do anything more than switch back to good old nv. PPC & Intel have different architecture with different endianness. It's quite hard to manage this and reverse-engineer how the hardware is working : I guess you should not expect a fix for this in new versions of nouveau.

There's also a quite good proprietary driver made by NVIDIA.

share|improve this answer
    
The nVidia proprietary driver isn't available for PowerPC machines (as is the case), sadly. The only options one has in this case are nouveau and nv. –  Renan May 20 '12 at 20:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.