Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed SourceMage Linux on my laptop and the ethernet and wireless interfaces don't exist after loading the required modules (tg3 and ath9k). On other distros (Xubuntu, aptosid) the networking worked.


02:00.0 Ethernet controller: Broadcom Corporation Device 1692 (rev 01)
08:00.0 Network controller: Atheros Communications Inc. Device 002e (rev 01)
share|improve this question
What are the linux (kernel) versions that work and that don't? Your issue probably has more to do with the kernel version than with the distro. – njsg Feb 5 '12 at 14:06
@njsg It works with kernel version 2.6.32-5(CrunchBang) and doesn't with – RunningDroid Feb 6 '12 at 22:17
Which network devices are these? There are some changes concerning network device support in 2.6.32 (although there are probably new devices in every release) - check if some of these is the card you're using. If not, go back version by version until 2.6.28 and inspect the network devices section. If you find your card there, then 2.6.27 doesn't support it and that's your problem. You just need a newer kernel (you can try using the one from CrunchBang in SourceMage). – njsg Feb 6 '12 at 22:56
@njsg I tried using the CrunchBang kernel and the interfaces still aren't there – RunningDroid Feb 17 '12 at 21:27

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.