Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After recompiling my kernel, I copied the corresponding files to /boot, and my /boot directory looks like:

enter image description here

Then, I inserted a new item in grub, and /boot/grub/menu.lst now looks like:

enter image description here

After searching a lot, I found that someone mentions that maybe ACPI settings matter. So, I set ACPI to off. But it still does not work.
When I reboot my OS, it still stops, like this:

enter image description here

As you can see, I have another grub item, grub-ide. And if I choose it, I can successfully log into it.

How can I get my system to boot with my new kernel?

share|improve this question
Recompile kernel again without making any changes that you did to it. Good start as always would be "make mrproper" to clean up. Use .config to your advantage if you are compiling kernel from kernel.org sources. – RailOcelot Feb 3 '12 at 5:42
i have already tried twice,but it still does not work.And by the way,i have rewrite something of the kernel at the fisrttime i boot the kernel.But i donn't think it's the problem. – kaiwii ho Feb 3 '12 at 10:14
What is vmlinuz-noexec and how does it relate to vmlinuz? The noexec bit makes me suspicious; Also, does booting the first entry without acpi=off help? (Also, note that it's not grub that's stopping, I think the "Uncompressing Linux..." part is already under Linux control (although I can't find it in the arch/x86/boot/compressed/misc.c, it lives there for other architectures).) – njsg Feb 3 '12 at 12:25
for the sake that i have changed something in the kernel,i recompile the bzImage and rename it as vmlinuz-noexec.So,u can see in my /boot directory there are vmlinuz which is the orignal version and the vmlinuz-noexec i have aready changed.And coming to acpi,at the first-time i set the grub item of the vmlinuz-noexec without acpi,but it does worked yet.And after long time searching,someone mention maybe the acpi setting matter,so i set the acpi to off,but it has no change yet – kaiwii ho Feb 4 '12 at 0:03
up vote 1 down vote accepted

The problem was nothing with the setting, but was about my own design of the kernel. After revising some of the bug, the kernel can be booted successfully: screenshot after successful boot

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.