Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an Apache 1.3 on a Sun machine (SunOS 5.10 Generic_138888-01 sun4u sparc SUNW,Sun-Fire-15000). If I keep the following two lines in httpd.conf, the server will not start:

LoadModule sm_module "/cmsm_sw/epiapr1/netegrity/webagent/bin/mod_sm.so"
SmInitFile "/apache/conf/WebAgent.conf"

This is all I get when I try to start Apache:

:/apache/bin # ./apachectl start
1392: CSemCounter created a semaphore with ID 1157627995 using key 989855746.

The mod_sm.so is the netegrity siteminder module (iPlanet).

Today there were some network issue (which were solved in the mean time) so I assume that this might have something to do. Maybe I should restart some services? I appreciate any help/hints.

share|improve this question

closed as off-topic by Jeff Schaller, sam, don_crissti, jimmij, slm Jul 1 at 19:59

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – Jeff Schaller, sam, don_crissti, jimmij, slm
If this question can be reworded to fit the rules in the help center, please edit the question.

    
does apachectl configtest give any clues? – Tim Kennedy Feb 2 '12 at 16:25
    
The configuration test works fine. It says "OK". Anyway, the issue was fixed and it seems that the cause was this: on the local machine there was a netegrity web agent that was communicating with a policy server (I believe iPlanet) and the communication from the policy to my server failed (hence the apaching hangs at startup when sisteminder .so module was loaded). It was solved with a restart of the policy server. I know, it was impossible to tell this without knowing the configuration. Anyway, thanks for your replies. – Razvan Feb 2 '12 at 20:52
up vote 2 down vote accepted

Given the part of the message "semaphore with ID 1157627995 using key 989855746", I'd say this module uses SysV IPC primitives. Use the ipcs command to see how many semaphores, how many shared memory segments, etc exist. The network problems may have caused the module to create semaphores and not delete them. Or something. I seem to recall that a pretty low limit on number of semaphores and/or shared memory segments exist by default, so you may be running afoul of those limits.

share|improve this answer

It seems that, indeed, there was a network issue. Trying to telnet from the client machine to the server machine on port 44441 failed.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.