Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need xfontsel to select right font for xterm. But its not installed. I tried yum but it returned

Warning: No matches found for: xfontsel
No Matches found

I googled for xfontsel source code to compile myself but didn't get any link for that.

  1. How can I install xfontsel on Fedora 13?
  2. Its not installed by default and neither it is available in yum repo. So does this mean Fedora will not include it anymore? Why?
  3. Any alternative to xfontsel? I tried xlsfonts but it does not give preview of fonts.

Thanks for your time and help.


$ su -c "yum install xorg-x11-apps.i686"

This did the trick on my Fedora 13.

share|improve this question
"yum install /usr/bin/xfontsel" (or perhaps just "/bin/fontsel") would have worked too. – vonbrand Jan 17 '13 at 23:41
up vote 3 down vote accepted

You can find out which package ships a given binary under Fedora like this:

yum provides "*bin/xfontsel"

however this only works if you know the name and directory of the executable. Indeed for xfontsel it is xorg-x11-utils as already stated by Michael:

$ yum provides /usr/bin/xfontsel
Loaded plugins: fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: mirror.nl.as6453.net
 * livna: ftp-stud.fht-esslingen.de
 * rpmfusion-free: mirror.telepoint.bg
 * rpmfusion-free-updates: mirror.telepoint.bg
 * rpmfusion-nonfree: mirror.telepoint.bg
 * rpmfusion-nonfree-updates: mirror.telepoint.bg
 * updates: mirror.nl.as6453.net
xorg-x11-apps-7.4-13.fc13.i686 : X.Org X11 applications
Repo        : fedora
Matched from:
Filename    : /usr/bin/xfontsel

xorg-x11-apps-7.4-14.fc13.i686 : X.Org X11 applications
Repo        : updates
Matched from:
Filename    : /usr/bin/xfontsel

xorg-x11-apps-7.4-14.fc13.i686 : X.Org X11 applications
Repo        : installed
Matched from:
Other       : Provides-match: /usr/bin/xfontsel
share|improve this answer
You say it's in xorg-x11-utils yet in the output we see xorg-x11-apps. Why the difference? – Piotr Dobrogost Nov 26 '14 at 10:08

It's not necessarily in its own package, and it's not necessarily in a package named xfontsel. This site leads me to believe it's part of xorg-x11-utils, so installing that should work

share|improve this answer
It looks like it's part of xorg-x11-apps now (Fedora 21). – Piotr Dobrogost Nov 26 '14 at 10:35

Besides the above mentioned binary rpm's for Fedora, the xfontsel source code is available from X.Org at http://www.x.org/releases/individual/app/xfontsel-1.0.3.tar.bz2

share|improve this answer
Thanks a lot alanc. I googled for the source code but didn't find it. Really appreciated! – Andrew-Dufresne Oct 20 '10 at 2:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.