Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have been using Linux on my Acer 5740 for a couple of years now. Lately, I noticed that my computer starts heating up and steadies at around 70 degrees. If I fire up Eclipse or ffmpeg or something, the computer shoots to 85-90 degrees. Maybe this has happened before but I might have ignored it.

I have a dual-boot with Windows 7 and 70 degrees is the maximum even when I play games.

I expect Linux to heat up a little because of drivers but 70 degrees @ idling is a little too much.


My prior research on this shows:

  1. A friend of mine with exact same Laptop but with an ATI card instead of the Intel (present on mine) was struggling with heat problems of much greater intensity. He installed fgrlx and his Laptop is as cool as Siberia.

  2. I have attempted to install Intel drivers for my card. I have the latest version of Xorg and xorg for Intel. It doesn't help.

  3. The problem is independent of Distribution. I have tried Ubuntu, Debian, Fedora and FreeBSD.

  4. The graph for temperature versus time after boot-up is fairly steady. There are no sudden jumps.

  5. All temperatures are in Celcius and correspond to max(acpi -t)


Any solutions?

Edit: My CPU if scaled at 933MHz still doesn't help. I can't find Fan Control for my Laptop. There are few scripts for Acer Aspire One but I can't find one for 5740.

My /proc/acpi/fan folder is empty!

 blah@blah-Laptop:/proc/acpi/fan$ ls -l
 total 0
share|improve this question
    
Have you disabled CPU scaling? –  Karlson Feb 1 '12 at 17:35
1  
Sounds like either CPU scaling is completely off, or your fans are not being managed properly (ideally the BIOS should manage it, but I have seen situations where a kernel module takes over). –  Chris Down Feb 1 '12 at 17:54
    
I have scaled CPU. See Edit. –  user14517 Feb 1 '12 at 17:59
    
Since you see a specific difference between the two os, and are scaling the CPU freq, in linux, that leaves the fan control. You might want to experiment with explicit fan settings, then examine ACPI setting. This article explains how to explicitly set the CPU fan speed via /proc/acpi/fan/FAN/state –  bdowning Feb 1 '12 at 18:31
    
Thats a beautiful article but the problem is my /proc/acpi/fan folder is empty! –  user14517 Feb 1 '12 at 18:36

3 Answers 3

up vote 3 down vote accepted

I'm running Arch Linux, and this is what I do to reduce heat emissions.

  1. I use laptop-mode-tools to control CPU frequency scaling and spinning down of the hard disk. The hard disk can heat up quite a bit if you keep it running continuously. But take note, spinning down of the hard disk too often will cause it to break. Desktop hard drives are usually rated for only 40,000-50,000 spinups. Laptop hard drives are usually rated for around 300,000 spinups. Link.

  2. I installed acpi_call Visit here or follow this post for instructions to disable/ activate your discrete card . For me, I disabled the discrete card and only make use of the integrated card.

  3. If you are using i915 drivers for your intel card, this will work. Check your output of lspci -mvknn | grep -B8 i915. If it returns non-empty, then you may add i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 to your boot parameters.

    pcie_aspm=force can also be added if all PCIe hardware on the system supports Active State Power Management.

    This post explains what does each of these parameters do.

I use steps to mainly to reduce power consumption, but I also noticed a drop in temperature of more than 10°C as a side effect. I guess with less power used, less heat is emitted.

share|improve this answer
    
Disabling the discrete video card using acpi_call is not recommended as it does not survive suspend. I recommend you to take a look at Bumblebee which uses bbswitch for switching power. –  Lekensteyn Feb 2 '12 at 9:50
    
sudo apt-get install laptop-mode-tools with some tweaking worked (at least for now). –  user14517 Feb 2 '12 at 20:26

Linux heats up your laptop because you need to install the right graphics card drivers (or wait till they are available) and some packages that help you manage the temperature, like spinning the disk at lower speed, and scaling the CPU correctly. I recommend you install powertop; it comes with several suggestions that will help you improve your laptop's performance.

share|improve this answer

I got the same problem with my FSC XA3530 and an AMD 3650 video card. I cut a hole in the back near the heatpipe and the fan then I add some extra cooper cooler and a laptop cooler. But the temperature is still very high and sometimes I get a thermal shutdown when I run some very intense applications like for example games. I disabled the cpu scaling to max out my cpu and I installed a self-developed kernel driver to control the fan. Out-of the box the fan isn't supported so without my kernel driver I can really forget about using this box. Lately I installed the latest fglrx driver and I noticed that the cpu temperature is much lower then with the open source driver?? Before the cpu idle at about 60°C+ now it is idle at 40°C+??? Maybe it's worth to mention that there is only 1 big heatpipe with 3 cooler and 1 fan. This is only a quick resume because I have installed fglrx since a couple of days ago. I wouldn't trust it because of my add-ons and my self-developed kernel driver but I suggest you to install a kernel driver and do it yourself? There is also a perl script for some Acer box. Maybe it works for you? It helps me a lot to get my kernel driver working. Perhaps you need to find the right register in the embedded controller? There is usually one for the fan mode and one for the speed. It's easier in Windows with the RW tool. In W7 the situation hasn't changed even with new drivers.

share|improve this answer
1  
For controlling the EC, you can take a look at aceracpi.googlecode.com/svn/trunk/acer_ec/acer_ec.pl –  Lekensteyn Feb 2 '12 at 9:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.