Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I just bought an HP pavillion g6 laptop, with the hope of installing Linux on it. I have now tried both Linux Mint (my first choice) and Ubuntu, and both simply give me a black screen from the moment it begins loading the Live CD. I think it reaches the login screen, I can hear the start-up jingle, but all is just black.

Mint gives an "Automatic boot in 10...9..." screen, then goes black. I can stop the countdown and pick from a few options, I tried the "compatibility mode" but that didn't help. The other options are integrity and memory checks, or to boot from the harddisk.

Ubuntu also shows a brief purple screen, where I can escape and either try it or install it. Given the problem I'm having I don't want to install just yet, so I haven't tried that. Picking "Try Ubuntu" I get a black screen immediately after.

Google turned up a suggestion of pressing CTRL+ALT+F2 after it has finished loading, to get a shell, but that doesn't seem to do anything.

I also searched through the BIOS options and set "Switchable Graphics Mode" to Fixed instead of Dynamic, but that didn't help either (so I've switched it back again).

I'm out of ideas. I'd prefer to get Mint to work, since I'm tired of Ubuntu and want to try out Mint instead.

Update I am able to get it to work by setting the nomodeset boot option, but without that I still get a black screen (I can just barely make out some elements on the screen, but it's very, very dark). I tried installing the proprietary ATI drivers in the Additional Drivers window, but that didn't seem to help, or they weren't installed properly, I can't seem to tell.

share|improve this question
    
have you tried booting from sysrescuecd? any other distro? I'm curious if you can get a basic console and optionally start a thin, simple X11. –  bdowning Feb 2 '12 at 16:52
    
@bdowning Sysrescuecd? The only thing I can think of like that is Mint's "compatibility mode" which as mentioned didn't work. I haven't tried any other distros than the ones mentioned, my only experience with other distros was years ago and I never liked them much. I would be very surprised if a console didn't work, but I'm not sure how to get one. –  ADCoon Feb 2 '12 at 18:22
    
sysrescuecd is a simple but powerful linux cd/usb that one can boot from to examine, repair, or "rescue" their system. It's based on gentoo with a comprehensive kernel and collection of utilities. You didn't mention if the laptop is new or used, works with other OS or not. I'd also try connecting the VGA cable to an external monitor if possible and see what happens. –  bdowning Feb 2 '12 at 19:12
    
It's a brand new laptop, works fine with Win7. I tried an external screen and it works fine. Strange thing, if I use the external screen and then close and reopen the lid on the laptop, the laptop's screen starts working too. I also tried sysrescuecd; its default boot doesn't work, same problem, but I can start it in "framebuffer console in high res" mode and manually start X from there, which works just fine. My problem seems to be Kernel Mode Setting (KMS), I've turned it off in my grub config and things are working now, but I don't know if that's the optimal solution. –  ADCoon Feb 3 '12 at 13:45
    
I've had great success with the ATI proprietary linux drivers on my machines with Radeon cards. After installing you need to follow the on screen instructions to configure the initial xorg.conf. –  bdowning Feb 3 '12 at 14:23
show 2 more comments

6 Answers

up vote 2 down vote accepted

There's a launchpad bug about Ubuntu booting with the laptop backlight off; that might be the problem you're seeing.

share|improve this answer
    
Thanks for the link, seems that is the actual problem. –  ADCoon Feb 7 '12 at 8:28
add comment

Any of these tips does not work for me. I can see boot options and I can edit it, but nothing works. But finally, I have found a SOLUTION:

In our BIOS disable secure boot and it will run!

Hope it helps. ;)

share|improve this answer
add comment

Boot to Linux Mint and then hit TAB to edit startup and add at the end: acpi_backlight=vendor.

share|improve this answer
add comment

I had the same problem on my Pavilion g6-1290ev, and it turned out I only needed to increase the brightness (by pressing F3).

share|improve this answer
add comment

You'll need the official Catalyst driver available from AMD.. had the same issue with mine. (and the nomodeset so you can see what you're doing, but you've already gotten that far).

I realize this question is quite old, but I'm submitting this hoping that anyone viewing it in the future gets a working computer out of it.

share|improve this answer
    
I guess I'll leave this if it might solve the problem for other people, but the OP already tried it: "I tried installing the proprietary ATI drivers in the Additional Drivers window, but that didn't seem to help" –  Michael Mrozek Dec 17 '12 at 14:44
add comment

When see the grub menu, press e, and add nomodeset, then press ctrl+x, have a try.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.