Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Fedora 15 server that has been running just fine for months until I suffered a power outage. After the recovery, all services came back up just fine except vncserver. When I try to start the daemon with the following command:

# service vncserver start

I get the following:

Starting vncserver (via systemctl): Job failed. See system logs and 'systemctl status' for details. [FAILED]

I've looked in /var/log/messages and could not find the culprit. Doing a systemctl status vncserver.service yields the following:

vncserver.service - LSB: start|stop|restart|try-restart|status|force-reload vncserver
Loaded: loaded (/etc/rc.d/init.d/vncserver)
Active: failed since Mon, 23 Jan 2012 22:57:11; 1min 28s ago
Process: 4701 ExecStart=/etc/rc.d/init.d/vncserver start (code=exited, status=126)
CGroup:name=systemd:/system/vncserver.service

Please keep in mind that the problem does not lie in the vncservers, iptables, or xstartup files as all of these were working perfectly before the outage; they have not changed, and I have exact duplicates of these files on another machine that run just fine as-is. Uninstalling and reinstalling from RPM does no good.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

Have you tried to run it just like that ? : /etc/rc.d/init.d/vncserver

share|improve this answer
2  
That's what it was! Thanks to your suggestion, I found a still-in-use but corrupt session in /tmp/.X11-unix/X15. Deleting the X15 file solved the issue. Thanx! –  Anthony Jan 31 '12 at 22:36
    
@Anthony There's a checkmark on the left you can click to accept this if it solved the problem –  Michael Mrozek Jan 31 '12 at 22:40
add comment

I changed VNCSERVERS to VNCUSERS, e.g.:

VNCUSERS="2:username"
VNCUSERARGS[2]="-geometry 1280x1024"

Then:

service iptables stop
service vncserver start

Now it works.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.