Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

I don't like, don't care about, don't want notifications from my window manager. Ever.

Example: Since I manually removed the virtuoso-t package, my computer doesn't spend ages trying to index its own files. I consider that a good thing. When I start KDE, I get a notification that the Nepomuk RDF service cannot work properly without virtuoso. So I have to waste a click closing that window.

I also don't update my packages just because there happen to be new versions of things out. I generally wait a while.

When I use apt-get, which is a lot, I get a notification that there are a number of new 'system updates'.

Every single time.

Like punishment.

I'm not interested in using LXDE or XFCE. I prefer pure KDE in a lot of ways. But if I could suppress all of KDE's messages, more in line with the 'no news is good news' user experience, that would really be superb. I'd have so many fewer windows to close at various intervals, after all.

share|improve this question
you may find that if you update to a new kde (4.8 just came out) you'll get a lot less in the way of notifications. Also you may find the notifier more configurable. Just saying that your KDE is 2 years old. Also nepomuk is disableable in resent versions as well as being able to disable applications notifications – xenoterracide Jan 31 '12 at 4:02
@xenoterracide thanks. it turns out i've got 4.6 ... – ixtmixilix Feb 1 '12 at 13:21

2 Answers 2

You can remove the annoying, badly-written English passive voice ('It is recommended' rather than 'your system needs updating') notifications simply by uninstalling the package that provides for them:

root@ROOROO:/# apt-get remove update-notifier-kde

As for the rest of the notifications, I'll edit this answer if I find out how to remove them...

share|improve this answer
First, your link is broken somewhat (the paragraph seems to have been retitled). Then, if you fix it, you'll face the opposite section giving arguments for passive voice. So the link, even if fixed to modern title of the chapter you reference, will still look single-sided thus subjective. – Ruslan Sep 5 at 19:15

In KDE 4.8 (sorry I don't have access to anything older ) you can click on the "show hidden icons button" in your panel, then right click on "notifications", click "notification settings". Here you will see some options on what to show. However each application has it's own menu for what events it has send notifications.

screenshot of where notifications can be accessed and the available settings

An even Better option might be to go to the K menu, click system settings, click desktop search, and disable all of the enable desktop search services. You didn't have to unistall virtuoso, just disable nepomuk via settings. nepomuk settings

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.