Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm trying to boot a Fedora Rawhide LXC container from a Fedora 16 host, and it's not working - systemd just keeps dropping into emergency mode. Because udevd doesn't work in LXC containers, I thought I'd try disabling udevd inside the guest, but I can't manage to do this.

You'd think that

systemctl disable udev.service

would do the trick, but it doesn't. I can see that udevd is still being spawned by running pstree in the host.

share|improve this question

1 Answer 1

The command is systemctl to control the services under systemd

to disable the service from running next time: systemctl disable udevd.service

to stop the service currently running : systemctl stop udevd.service

Go through these doc links from the author of systemd

http://0pointer.de/blog/projects/systemd.html

http://0pointer.de/blog/projects/on-etc-sysinit.html

They are lengthy, but worth a leisure reading, and yet important, since major Linux distributions are having this crucial time to leap into next leg of improvement/enhancements with systemd, leaving behind some (old school of thoughts) SysV style operations.

share|improve this answer
    
Sorry - I made a couple of typos. That's basically what I did, but it doesn't work. –  Robin Green Jan 30 '12 at 21:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.