Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm having a problem in the top menu panel since a couple of days, some space has been created between some icons and I don't know how to remove it. A screendump:

alt text

Does anyone know what the reason could be for it?

By the way, I'm using Ubuntu Lucid (should I ask in the ubuntu site?).

Thanks

Edited: This is how it looks like now, still one blank space, but much better (I guess it has something to do with the question from Michael's link)

alt text

Edit 2: After a reboot, the blank space was gone so solved :)

share|improve this question
    
This question might explain the cause –  Michael Mrozek Oct 11 '10 at 20:19
1  
I have the exact same problem. Have you been able to solve this problem permanently? Although rebooting solves the problem for me as well, this is not really a solution. –  Aron Rotteveel Jan 28 '11 at 8:09
add comment

1 Answer

up vote 3 down vote accepted

As far as I can see from the screenshot, it could be either of two things.

It doesn't look like the spacing between icons as defined by gnome is off, but just to make sure, you could run:

gconftool-2 --type int --set /apps/panel/toplevels/top_panel/padding 0
gconftool-2 --type int --set /apps/panel/toplevels/bottom_panel/padding 0
gconftool-2 --type int --set /apps/panel/applets/systray/prefs/padding 0  

The other possibility is that due to a resolution change your icons on the panel got stuck out of position. This is really annoying, and if the icons are locked they won't automatically swap back into place when you switch to the previous res. This happens a lot with dynamically resizable VMs.
To deal with this, make sure that the icons are unlocked (right click, untick "Lock") and then move them back to where they belong.

Please let us know if this resolved your issue.
Regards.

share|improve this answer
    
I unlocked the panel and I could move it to the right (I would have swear that I tried this yesterday and it didn't work, but it did now!). There is still one space on the left though, but at least is not so bad now as it was before. I'll post an screenshot. (BTW I ran your three commands and nothing changed =( ) –  oli206 Oct 11 '10 at 20:55
    
@oli206 // Those three commands have noticeable effects on default gnome installations. Ubuntu does tweak gnome for you. I've needed them in Arch / Fedora / Gentoo. >D. Glad you could solve your issue. Cheers! –  wormintrude Oct 13 '10 at 13:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.