Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running Linux Mint and I'm trying to edit my symbol files but none of the changes stick - I've tried restarting X and restarting the computer. Eventually I got frustrated and tried deleting the symbols directory (well, moving it to the parent directory), and if that had made a difference I'd revert the change using a TTY. I restarted the computer but I can still type - why is that?

More information: the only directories I have found relating to xkb (I used locate xkb), are those in /usr/share/X11/xkb and its subdirectories, and so these are the files I've been editing.

share|improve this question
    
Did you ever work this out? I have a similar problem, that I was just about to migrate to this site instead. askubuntu.com/questions/330885/… –  Sparhawk Aug 14 '13 at 6:25

1 Answer 1

There is a tool made by XFree/X.org in order to alter your symbol / key mapping. It is xmodmap. See this post for a nice explanation about it from ArchLinux community. Default keyboard configuration file on Debian-based Linux (Ubuntu, Linux Mint, etc) is in /etc/default/keyboard.

You can also do that with tools like getkeycodes / setkeycodes or dumpkeys / loadkeys. Take note that those tools works only in a real console, not a xterm. You'll need to use CTRL+ALT+FX.

share|improve this answer
1  
Supposedly, xkb is now preferred over xmodmap anyway. –  Sparhawk Aug 14 '13 at 6:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.