Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I'm at work, I use KDE activities and map them to my projects. I always use the same applications on every project, so I'd like to keep my windows visible when I change the activity. For the moment, what I do is go through every window, right click on the title bar, and check the checkbox that makes the window appear on all activities. How can I configure my windows default value for this choice? I'd like every window to appear on all activities by default.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

This question may be old, but I think I have found the perfect solution.

  • Go to System Settings > Window Behaviour > Window Rules
  • Add a new Rule
  • Mark all window properties as 'Unimportant'
  • Select all 'Window' types like in the screenshot Select all 'Window' types
  • In the tab 'Size & Position', tick 'Activities' and configure it as 'Apply initially' and 'All Activites', like in the screenshot In the tab 'Size & Position', tick 'Activities' and configure it as 'Apply initially' and 'All Activites'
  • Click 'Ok'

This should set all windows to be on all activities by default.

share|improve this answer
    
Looks awesome! I can't wait to test that at work tomorrow! And yes, the question is old, but the problem is still very present. –  greg0ire Jan 8 at 21:08
1  
Woops, forgot to test until now, but it works like a charm! Many, many thanks! –  greg0ire Jan 16 at 14:27
add comment

It's not elegant, but might help. Idea that comes to my mind is to search for such windows with xwininfo or xdotool search --name WINDOWNAME and then try to "inject" mouse clicks or - this is easier - keystrokes ( example: xdotool search --name WINNAME key ctrl+c. that results in such setting ( "alt+space" usually gets WM window options, later arrows... this should be possible to do by keystrokes injection ).

share|improve this answer
    
Not very elegant indeed, but if there is no other solution, I guess I should look into that... –  greg0ire Jan 26 '12 at 21:47
    
That's why I've wrote it. If nothing better will be around, try this shot. –  Grzegorz Wierzowiecki Jan 26 '12 at 23:43
    
I will, thanks. –  greg0ire Jan 27 '12 at 9:00
    
I've tried to find out on community.kde.org/Main_Page and techbase.kde.org/… and api.kde.org , but with no success. –  Grzegorz Wierzowiecki Jan 27 '12 at 21:01
    
It seems there is no solution just the workaround you and I proposed... for the moment –  greg0ire Feb 5 '12 at 14:35
show 1 more comment

I asked the question here : http://forum.kde.org/viewtopic.php?f=111&t=98797&p=211999#p211999 and it appears not closing the windows when shutting the computer down makes them reappear on startup with the same options, which is a good workaround for this problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.