Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The wheel is Logitech driving force DFGT. The platform:

linux-dopx:/home/anisha/ # cat /etc/issue && uname -a 
Welcome to openSUSE 11.3 "Teal" - Kernel \r (\l).
Linux linux-dopx 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

To check the force feedback I did:

linux-dopx:/home/anisha/ # fftest /dev/input/event4
Force feedback test program.

Device /dev/input/event4 opened
Axes query:
Number of simultaneous effects: 0
Upload effects[0]: Function not implemented
Upload effects[1]: Function not implemented
Upload effects[2]: Function not implemented
Upload effects[3]: Function not implemented
Upload effects[4]: Function not implemented
Upload effects[5]: Function not implemented
Enter effect number, -1 to exit

fftest failed with Function not implemented message.
The wheel is being detected through event4 and js0 files in /dev/input/

# cat /proc/bus/input/devices
I: Bus=0003 Vendor=046d Product=c29a Version=0111
N: Name="Driving Force GT"
P: Phys=usb-0000:00:1d.3-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:1d.3/usb5/5-1/5-1:1.0/input/input7
U: Uniq=
H: Handlers=event4 js0
B: EV=1b
B: KEY=1f0000 0 0 0 0 0 0 ffff00000000 0 0 0 0
B: ABS=30007
B: MSC=10

How to counter this? No, I am not running any game. I just wanted to apply these effects to my wheel.

I even tried modprobe hid-logitech and modprobe hid, they didn't help.

Please help.

share|improve this question
up vote 2 down vote accepted
  • I replaced the label LOGITECH_FF with LOGIWHEELS_FF in the file /usr/src/linux-2.6.34-12/drivers/hid/Kconfig.
  • Set default y as shown below:
    bool "Logitech force feedback support"  
    depends on HID_LOGITECH  
    default y  
    select INPUT_FF_MEMLESS  
      Say Y here if you have one of these devices:  
      -Logitech WingMan Cordless RumblePad  
      -Logitech WingMan Cordless RumblePad 2  
      -Logitech WingMan Force 3D  
      -Logitech Formula Force EX  
      -Logitech WingMan Formula Force GP  
      -Logitech MOMO Force wheel  

      and if you want to enable force feedback for them.
      Note: if you say N here, this device will still be supported, but without
        force feedback

The fftest worked with constant force as shown below.

linux-dopx:/home/anisha/ # fftest /dev/input/event4
Force feedback test program.

Device /dev/input/event4 opened
Axes query: 
Effects: Constant 
Number of simultaneous effects: 16
Upload effects[0]: Invalid argument
Upload effects[2]: Invalid argument
Upload effects[3]: Invalid argument
Upload effects[4]: Invalid argument
Upload effects[5]: Invalid argument
Enter effect number, -1 to exit
Now Playing: Constant Force
Enter effect number, -1 to exit

Thanks to: Simon from linux-input mailing list.

share|improve this answer
Brainy.. +1 :-) – Nikhil Mulley Jan 18 '12 at 5:35
I was referring to you, brainy :-) – Nikhil Mulley Jan 20 '12 at 5:55

Some users have reported that testing /dev/input/eventX, and after /dev/input/js0 was the key for them.

An other has tried every possible /dev/input/eventX and finally found a working one.

But it's quite possible that this joystick is not well supported by Linux. On vdrift wiki, they show how to make a quick patch in order to get a G25 works. Since your Suse Kernel has recognized its name, you should not need to do that. You can also take a look at your dmesg and see if Force Feedback is activated in Suse Kernel, like it's now the case in Ubuntu

share|improve this answer
Thanks for the reply, but I managed to solve this. – TheIndependentAquarius Jan 18 '12 at 5:00

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.