Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try and push --all to GitHub, the Git transfer starts out fast, slows down, and eventually stops. It doesn't fail, it just slows to a halt. What's going on? This is really frustrating, I'd like to get my code pushed, but every time I try this, it slows to a stop. I've tried on multiple networks, so I don't think it's my network connection.

share|improve this question
What's the output of git config -l? – user13742 Jan 16 '12 at 20:54
I was able to force it through by just trying over and over again; when I ran it with -v (verbose mode) it worked better for some reason and was able to complete. – Naftuli Tzvi Kay Jan 16 '12 at 20:54
Are you using https? For large repositories, https might be slow. You can try using the ssh address instead. – Daniele E. Domenichelli Mar 14 at 9:03

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.