Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top
Response:   220-This is a private system - No anonymous login
Response:   220 You will be disconnected after 60 minutes of inactivity.
Command:    AUTH TLS
Response:   234 AUTH TLS OK.
Status: Initializing TLS...
Error:  GnuTLS error -50: The request is invalid.
Error:  Failed to initialize TLS.
Error:  Could not connect to server

I'm trying to connect to a site using FTPES. It worked before on Fedora/Filezilla. But now I'm using Scientific-Linux with Filezilla, and it gives this. What am I missing?

share|improve this question
Nothing personal, but you obviously need to do some more research on SL before asking about everything here. – user13742 Jan 13 '12 at 23:12
so your saying that this is not a filezilla-related bug? – LanceBaynes Jan 13 '12 at 23:16
up vote 2 down vote accepted

With FileZilla 3.5.2 it works perfectly. With FileZilla 3.5.3 it produces the error message above. So it's a bug AFAIK.

share|improve this answer

The error caused by the GnuTLS Handshake Failure between the client and server. So, There is no issues with the ftp client - filezilla or TLS.Issues might be lies on firewall setting of your linux box

share|improve this answer
I disable iptables and load ftp_conntrack, but it's still the same! – LanceBaynes Jan 14 '12 at 9:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.