Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have configured a L2TP VPN on Ubuntu server 11.04, and I can connect to it with a Mac client.

But after connecting successfully to this L2TP VPN, my Mac cannot access the internet. To access the internet, I have to disconnect from the VPN. My local IP address on Mac is, after connecting to VPN, I use this IP:

How can I fix this?

share|improve this question

You have 2 possibilities here. I can tell them to you, but you will have to find the specific settings for each one. I don't have mac at hand right now:

  1. On the mac, when you are connected to the VPN you should also have your old IP (192..). On the VPN settings window there should be an option for using the Internet over the VPN or over the default gateway. The problem is that you gateway is changed from 192... to the VPN pear 10... This solution will let you navigate on the Internet over the 192 network and access the VPN stuff over 10 network.

  2. On the VPN server, you could allow traffic forwarding (Internet access) from connected clients. This solution will allow the mac to navigate on the Internet over the VPN, the 10 network.

Hope this helps, maybe someone can give more specific answer with configuration examples.

share|improve this answer

The Problem is that your VPN-CLient sets the default route to the VPN-connection.

In Windows you can address this issue by unchecking "Use remote network as default gateway" in "Advanced Settings for IPv4".

KDE-Network-Manager works somewhat similar.

Open the Connection, Tab IPv4 Address, switch from "Basic" Settings to "Routes" and check "Use only for Ressources of this Connection".

In MacOS there should be something similar. The point is to tell the VPN-Client to not redirect all traffic via the tunnel, only the traffic that has the remote tunnel end as destination.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.