Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Buffalo WZR-HP-G300NH2 and I'm trying to get USB support working. The original Buffalo-branded firmware would refuse to mount the USB drive, so I've followed what tutorials I've found for DD-WRT. I've tried ssh-ing into the box and mounting it with

mount /dev/sda /mnt

as root, and it fails with invalid arguments.

For USB file formats I've tried EXT3 and XFS. XFS is the user-friendly firmware file format.

I can enable FTP in the DD-WRT GUI and log in, but transferring anything bigger then 5MB to the 500GB attached drive causes the router to reboot.

I've downgraded to the Buffalo user-friendly firmware and it seemed to work, but I would like to get DD-WRT running; currently I'm running build 18024.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.