Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I recently started using a live USB version of BackTrack 5 R1 (A kubuntu-based distro), but I can't find any way to enable access to my home WiFi network. I can't find any comprehensive tutorials on Google, and BackTrack's wiki on the subject is vague at best. How can I connect it to my home wireless?

share|improve this question

migrated from security.stackexchange.com Jan 8 '12 at 23:34

This question came from our site for Information security professionals.

    
You are working from a live distro where installing applications each time you launch it a good solution. This makes your question very specific to the distro that you are using. In a case like this, its usually best to seek help from the distro's support rather than a general place such as this. –  jordanm Jan 9 '12 at 0:55
1  
i've never used backtrack, but networking has been around since the earliest flavors of unix and is built-in to its very structure. why not just learn to edit /etc/network/interfaces with the relevant info? that's all i do now to access my wifi networks. –  ixtmixilix Jan 9 '12 at 13:54
    
@ixtmixilix know about that... but i cant access any of the relevant info on the host computer. when i type ipconfig /all it just says "windows ip configuration" and nothing else –  That Guy Jan 9 '12 at 19:56

4 Answers 4

Backtrack 5 R1 comes with wicd packaged. Wicd is a lightweight GUI network manager. I assume you know how to startx and not attempting to connect to wireless through the console. That would call for a different answer.

  • Open the Wicd network manager in Applications > Internet > Wicd Network Manager (you may also click the tray icon if present). Or start it from the command line $ wicd.

  • See if the wireless network you're looking for shows on the list. If it is a hidden network, click the down arrow next to the Network button, and type in the ESSID of the network.

  • If the network you want to connect to is listed, press the "Connect" button next to it.
  • If you get the message "This network requires encryption to be enabled." hit OK, and key in your WEP / WPA / WPA2 key.
share|improve this answer
2  
Or you can try running wicd-curses in your terminal, if you're so inclined. –  Herman Torjussen Jan 9 '12 at 11:33
    
Console: use of iwconfig, iwlist, ifconfig, and possible dhclient. –  Jeff Ferland Jan 9 '12 at 17:22
    
yes i have seen wicd, but when i enable my networking with the command service networking start the wireless network still will not show up. it is not a hidden network, and it is perfectly visible when i run Ubuntu –  That Guy Jan 9 '12 at 19:58
    
@ThatGuy service networking start turns the interfaces "on", but wicd is where you need to put the credentials so it can connect. –  Novice User Jan 10 '12 at 18:03

Just launch wicd-gtk, since you're using the root user, wicd daemon will start automatically by you, and configure it in GUI. (There's a tray icon on the panel, right-most)

share|improve this answer

I've had this error as well, following the instructions on backtrack wiki you can solve the issue with the nektwork connection, the principal problem is the WICD that doesn't start and you cannot connect automaticaly.

/etc/init.d/networking start

dpkg-reconfigure wicd

update-rc.d -f wicd defaults

And this whould do the trick, also I reccomend to you that visit and suscribe on the backtrack forum,the link for the answer and also the wiki

share|improve this answer

Solution:

type the following in command prompt:

iwconfig

copy the name of wifi card: example wlan0

open wicd network manager--->preferences in the box "wireless interface", paste or type the name of your wifi card: example wlan0

click ok and you're good to go.

share|improve this answer

protected by Community Jun 11 '13 at 14:16

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.