Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an ASUS P5Q deluxe from an old gaming computer that I'm converting to a server. Unfortunately, while their silly onboard fake RAID thing(drive xpert) worked fine in Windows, the drives are not being detected at all when I attempt to install openSUSE to them. I've tried disabling it and setting it to "normal" but still no luck. The other SATA ports are detected without issue, but they're for my storage drives. Eventually I decided the better option might be a pcie SATA card, but I'm not positive it will solve my problem:

Will I be able to install to drives attached through a PCIE card? If so is there a specific card anybody could recommend?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

As a rule of thumb, always turn off fakeraid (RAID which is declared in the BIOS but actually performed by an OS driver). Fakeraid only exists for two reasons:

  • because some OSes have no native RAID capabilities and need some external assistance;
  • because it lets hardware manufacturers advertise a feature that they aren't really implementing.

There is no advantage of fakeraid over Linux RAID, only downsides such as the reliance on a specific driver and hardware.

With some motherboards (or more precisely with some RAID BIOSes), you can't turn off RAID modes if the drives contain a valid RAID signature. You need to wipe off this signature. Boot from a Linux CD and zero out the first few kilobytes and the last few kilobytes of the disk (or the whole disk, if you have time to spare). Note that this will remove all the data on the drive; if you want to save some data, you will probably need a more complex strategy involving temporarily removing the drives (or plugging them in the non-RAID SATA ports). Then reboot and go back into the BIOS, and you should see an extra option that lets you really turn off RAID.

share|improve this answer
    
I'm not concerned with preserving the data, they're just not being detected in the first place. Perhaps if I install in the non-raid ports first as you suggested, it will solve my dilemma. I feel silly not thinking of that myself. –  Daniel Ball Jan 9 '12 at 0:25
    
So far so good. It's a bit of a clunky solution but it's a solution I can live with. –  Daniel Ball Jan 9 '12 at 6:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.