Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My sound volume control does not work when I'm logged in with my regular user, though the sound works correctly. What's weirder is that the sound control works when I'm logged in as guest.

With my regular user I can't see any output peripherals in Preferences->Audio but it will show up when logged in as guest.

The home directory of my regular Ubuntu user is also used as the home directory of my Mac Os X user. Could it be the case there is some kind of conflict? I already tried deleting the .pulse directory and .pulse-cookie but nothing changed. Only .pulse-cookie was recreated when I logged out/logged in.

Do you have any idea of what could be happening?

share|improve this question
1  
What exactly is your "invited session" user? Have you enabled sound permissions for your regular user e.g. added it to the audio group? –  Herman Torjussen Jan 8 '12 at 13:14
    
I'm sorry I probably meant guest session. I do belong to the audio group. –  Such Jan 8 '12 at 13:47

1 Answer 1

Maybe you could reinstall the ALSA Mixer

sudo apt-get install --reinstall linux-image-$(uname -r) 

What also works sometimes is reconfiguring your soundcard in the settings.

systemsettings -> sound -> Hardware input/output
share|improve this answer
    
Thank you for your help. I had already tried reinstalling the alsa mixer with no effect. The thing is I actually had nothing showed in Hardware input/output. –  Such Jan 9 '12 at 20:16
    
In the end, I moved my home back to /home and I have no more issue. I think it was a bit silly tring to have both mac os x and ubuntu home pointing to the same folder. I had right issues that could explain the sound problem. –  Such Jan 9 '12 at 20:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.