Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Upon going to the user themes extension webpage, I get the following message:

This extension is incompatible with your version of GNOME. This extension supports the GNOME unstable release, 3.3.2

I have Gnome Version 3.2.1 according to System Info. So how would I go about installing the lastest unstable Gnome releases?

EDIT: I am running Fedora 16

EDIT 2: I would like to know if there is a repository to be installed so that I can simply yum update to the latest Gnome development version (downloading and installing gnome-shell-3.3.3 from here or here gives me an error with a list of dependencies yet to be satisfied)

EDIT 3: I remember successfully installing gnome-shell-extension-user-theme via yum a few months ago that worked just fine with Gnome, anybody know how to install an older version of the extension that is compatible with Gnome 3.2?

share|improve this question
    
@Mat Thanks! I've added my OS –  wrongusername Jan 8 '12 at 8:04
    
Ok, I was even assuming the wrong distro altogether :) –  Mat Jan 8 '12 at 8:06

1 Answer 1

up vote 2 down vote accepted

You can build the latest GNOME Shell (sandboxed) using JHBuild pretty easily, as explained here.

Note that this doesn't care about which distribution you're using, so there might be another way, i.e., some Fedora analogue of using experimental packages on Debian, that I don't know of. (I found this 3.3.3-1 GNOME-Shell package as an indication that there is something like a devel package, but I don't know how to make use of it.)

share|improve this answer
    
Thanks for the info! It seems a bit less daunting to install from a repository than by building from source, so I'm going to try to find the repo first :) –  wrongusername Jan 8 '12 at 21:36
    
While building from source might seem daunting, JHBuild really makes the whole thing easy as pie. (And sandboxed, i.e., you won't mess your system with it.) –  sr_ Jan 9 '12 at 8:19
    
It sounds nice, but I got frequent errors like Error running ./autogen.sh --prefix /home/amosng/gnome-shell/install --libdir '/home/amosng/gnome-shell/install/lib64' --disable-static --disable-gtk-doc with a list of options like "Rerun phase build," etc. I tried ignoring the error or giving up on the module, neither seemed to have much effect. I managed to fixed everything in the sanitycheck too. Interestingly, I remember installing all this from yum without trouble a few months ago. I guess an update made it now require Gnome 3.3, which I admit I am about to give up installing :( –  wrongusername Jan 10 '12 at 7:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.