Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I the libhighgui-dev package has unmet dependencies in 11.10. what should I do?

Synaptic says:

libhighgui-dev:
 Depends: libgtk2.0-dev but it is not going to be installed
 Depends: libjasper-dev but it is not going to be installed

where

libgtk2.0-dev:
 Depends: libgtk2.0-0 (=2.24.6-0ubuntu5) but 2.24.6-0ubuntu5linuxmint1 is to be installed
 Depends: libpango1.0-dev but it is not going to be installed
 Depends: libcairo2-dev but it is not going to be installed
 Recommends: debhelper but it is not going to be installed

and so on..

Update: /etc/apt/sources.list:

# deb cdrom:[Ubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)]/ dists/oneiric/main/binary-i386/

# deb cdrom:[Ubuntu 11.10 _Oneiric Ocelot_ - Release amd64 (20111012)]/ oneiric main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

## Major bug fix updates produced after the final release of the
## distribution.

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
# deb http://ir.archive.ubuntu.com/ubuntu/ oneiric universe
# deb-src http://ir.archive.ubuntu.com/ubuntu/ oneiric universe
# deb http://ir.archive.ubuntu.com/ubuntu/ oneiric-updates universe
# deb-src http://ir.archive.ubuntu.com/ubuntu/ oneiric-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
# deb http://ir.archive.ubuntu.com/ubuntu/ oneiric multiverse
# deb-src http://ir.archive.ubuntu.com/ubuntu/ oneiric multiverse
# deb http://ir.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
# deb-src http://ir.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.


## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
deb http://archive.canonical.com/ubuntu oneiric partner
deb-src http://archive.canonical.com/ubuntu oneiric partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu oneiric main
deb-src http://extras.ubuntu.com/ubuntu oneiric main
deb http://archive.ubuntu.com/ubuntu oneiric multiverse restricted universe main
deb-src http://archive.ubuntu.com/ubuntu oneiric restricted main multiverse universe #Added by software-properties

2nd update:

dpkg -l | grep linuxmint

prints:

ii  gir1.2-gtk-2.0                         2.24.6-0ubuntu5linuxmint1                The GTK+ graphical user interface library -- gir bindings
ii  grub-common                            1.99-12ubuntu5-1linuxmint1               GRand Unified Bootloader (common files)
ii  grub-pc                                1.99-12ubuntu5-1linuxmint1               GRand Unified Bootloader, version 2 (PC/BIOS version)
ii  grub-pc-bin                            1.99-12ubuntu5-1linuxmint1               GRand Unified Bootloader, version 2 (PC/BIOS binaries)
ii  grub2-common                           1.99-12ubuntu5-1linuxmint1               GRand Unified Bootloader (common files for version 2)
ii  libgail-common                         2.24.6-0ubuntu5linuxmint1                GNOME Accessibility Implementation Library -- common modules
ii  libgail18                              2.24.6-0ubuntu5linuxmint1                GNOME Accessibility Implementation Library -- shared libraries
ii  libgtk2.0-0                            2.24.6-0ubuntu5linuxmint1                The GTK+ graphical user interface library
ii  libgtk2.0-bin                          2.24.6-0ubuntu5linuxmint1                The programs for the GTK+ graphical user interface library
ii  libgtk2.0-common                       2.24.6-0ubuntu5linuxmint1                Common files for the GTK+ graphical user interface library
ii  libgtk2.0-dev                          2.24.6-0ubuntu5linuxmint1                Development files for the GTK+ library
ii  libplymouth2                           0.8.2-2ubuntu28-1linuxmint2              graphical boot animation and logger - shared libraries
ii  libyelp0                               3.2.0-0ubuntu1-1linuxmint1               Library for the GNOME help browser
ii  plymouth                               0.8.2-2ubuntu28-1linuxmint2              graphical boot animation and logger - main package
ii  plymouth-label                         0.8.2-2ubuntu28-1linuxmint2              graphical boot animation and logger - label control
ii  plymouth-theme-ubuntu-logo             0.8.2-2ubuntu28-1linuxmint2              graphical boot animation and logger - ubuntu-logo theme
ii  plymouth-theme-ubuntu-text             0.8.2-2ubuntu28-1linuxmint2              graphical boot animation and logger - ubuntu-logo theme
ii  python-software-properties             0.81.13.1-1linuxmint3                    manage the repositories that you install software from
ii  software-properties-common             0.81.13.1-1linuxmint3                    manage the repositories that you install software from (common)
ii  software-properties-gtk                0.81.13.1-1linuxmint3                    manage the repositories that you install software from (gtk)
ii  unity-greeter                          0.1.1-1linuxmint1                        Unity Greeter
ii  usb-creator-common                     0.2.34-1linuxmint1                       create a startup disk using a CD or disc image (common files)
ii  usb-creator-gtk                        0.2.34-1linuxmint1                       create a startup disk using a CD or disc image (for GNOME)
ii  yelp                                   3.2.0-0ubuntu1-1linuxmint1               Help browser for GNOME
share|improve this question

migrated from askubuntu.com Jan 6 '12 at 16:31

This question came from our site for Ubuntu users and developers.

add comment

1 Answer 1

up vote 1 down vote accepted

It's installable on Ubuntu. But it looks like you're using Mint from the 2.24.6-0ubuntu5linuxmint1 version. Please file a bug in Mint.

share|improve this answer
    
I don't know where the 'mint' come from. I'm on Ubuntu :-| –  sorush-r Jan 6 '12 at 13:56
    
What's in /etc/apt/sources.list.d ? –  tumbleweed Jan 6 '12 at 13:57
    
razor-qt-ppa-oneiric.list and razor-qt-ppa-oneiric.list.save. –  sorush-r Jan 6 '12 at 14:06
    
# deb ppa.launchpad.net/razor-qt/ppa/ubuntu oneiric main # deb-src ppa.launchpad.net/razor-qt/ppa/ubuntu oneiric main –  sorush-r Jan 6 '12 at 14:06
    
Hrm, try apt-get install libgtk2.0-0=2.24.6-0ubuntu5. Also, out of interest, what's the output of dpkg -l | grep linuxmint? –  tumbleweed Jan 6 '12 at 14:10
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.