Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using Linux Mint 12 and am having problems with the embedded terminal in gedit.

Using the default themes I'm unable to use 'ls' and 'byobu' as in part of their output foreground and background colours are the same.

Problems shown in this screenshot. Byobu is running (bottom two lines of terminal) and ls has just been used.

http://i.stack.imgur.com/BPboj.png

I've followed the instructions in http://askubuntu.com/questions/67593/make-gedit-embedded-terminal-colours-the-same-as-the-default-terminal but have had no luck with that.

Any ideas would be very appreciated!

share|improve this question

2 Answers 2

If you're experiencing this, you will need to edit /usr/share/byobu/profiles/common and comment out these two lines:

attrcolor b ".I"                                          
termcapinfo xterm 'Co#256:AB=\E[48;5;%dm:AF=\E[38;5;%dm'  

I've not yet figured out what combination of terminals experience this problem, but there is an open bug, and rest assured I'm working on it ;-)

share|improve this answer
    
Cheers for that! - I've moved to Ubuntu 11.10 using byobu within gedit and experience the same problem. That has currently fixed it but perhaps after a restart of the apps, I'll let you know –  CalumJEadie Feb 19 '12 at 9:46

I hope this helps, I can't test it. From the 'ls' man page:

-G Enable colorized output. This option is equivalent to defining CLICOLOR in the environment. (See below.)

CLICOLOR Use ANSI color sequences to distinguish file types. See LSCOLORS below. In addition to the file types mentioned in the -F option some extra attributes (setuid bit set, etc.) are also displayed. The colorization is dependent on a terminal type with the proper termcap(5) capabili- ties. The default cons25'' console has the proper capabilities, but to display the colors in an xterm(1), for example, the TERM variable must be set to xterm-color''. Other terminal types may require simi- lar adjustments. Colorization is silently disabled if the output isn't directed to a terminal unless the CLICOLOR_FORCE variable is defined.

CLICOLOR_FORCE Color sequences are normally disabled if the output isn't directed to a terminal. This can be overridden by set- ting this flag. The TERM variable still needs to refer- ence a color capable terminal however otherwise it is not possible to determine which color sequences to use.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.