Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using a Panda Board which is running a build of Angstrom.

The Panda Board has an in build Ethernet port and this is working fine, getting a DHCP address successfully.

I am going to be housing it in a larger container than the one supplied, which won't give me access to the internal port, so I am trying to use a USB Network Adapter.

Angstrom correctly identifies the adapter but it never gets a DHCP address. I've tried connecting both and just the USB one, but only the internal one will ever get an address.

Can someone help me? I'm new to linux!

Output of ifconfig -a:

eth0      Link encap:Ethernet  HWaddr 2A:40:E0:FD:3B:0A  
          inet addr:172.17.33.163  Bcast:172.17.33.255  Mask:255.255.255.128
          UP BROADCAST RUNNING MULTICAST  MTU:1492  Metric:1
          RX packets:112 errors:0 dropped:0 overruns:0 frame:0
          TX packets:59 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14645 (14.3 KiB)  TX bytes:11844 (11.5 KiB)

eth2      Link encap:Ethernet  HWaddr 00:0E:C6:88:F7:C6  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:62 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7116 (6.9 KiB)  TX bytes:4844 (4.7 KiB)

lo        Link encap:Local Loopback  
          LOOPBACK  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wlan0     Link encap:Ethernet  HWaddr 2A:00:E0:FD:3B:0A  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

The contents of /etc/network/interfaces:

wlan0
iface wlan0 inet dhcp
    wpa-conf /etc/wpa_supplicant.conf
    wpa-driver wext 



iface atml0 inet dhcp

# Wired or wireless interfaces
auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto eth3
iface eth3 inet dhcp

# Ethernet/RNDIS gadget (g_ether) or LAN9514
usb0
iface usb0 inet dhcp

usb1
iface usb1 inet dhcp

usb2
iface usb2 inet dhcp

usb3
iface usb3 inet dhcp

# Bluetooth networking
iface bnep0 inet dhcp
share|improve this question

2 Answers 2

Have you added your USB ethernet device to /etc/network/interfaces? I think you need to do that. (A similar entry like the one for eth0 -- you can find out which device it is via ifconfig -a. It should be listed there if it is recognized properly.)

Note that you can also do Networking using USB, that is, without an ethernet adapter but with some fiddling with host (your Workstation) and slave (the Angstrom device).

Apart from that, ifconfig -a output and your /etc/network/interfaces would probably be helpful to corner the problem.

share|improve this answer
    
Hi, thanks for that, but it didn't work still. Could you see the additional info above and see if I added the USB devices correctly? I orginally added the additional eth1,2,3. Does the usb ones need the Auto prefix too? Thanks! –  neildeadman Jan 5 '12 at 8:47
    
I'm not sure in which way the USB adapter appears in your system; assuming it's usb0, you could try ifup usb0 -- if this works, auto usb0 should solve your problem. But I'm unsure about this, I suspected the USB device should end up as an eth* device (check dmesg) in which case your configuration should already work. –  sr_ Jan 5 '12 at 9:13
    
still not working! :( any other ideas? –  neildeadman Jan 5 '12 at 10:29
    
Try dhclient -v {usb interface name} and see if the verbose output gives you any clues. Have you confirmed the usb interface works OK when addresses are set manually? –  ultrasawblade Jan 5 '12 at 12:22

If you bind the MAC address of the USB ethernet device in the DHCP server it should work.

share|improve this answer
    
How would I do that? –  neildeadman Jan 6 '12 at 8:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.