Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a sony VPCZ12 laptop. It has those dual video cards that are a pain to get working in linux. The new 2.6.35 kernel is supposed to support that with the vga_switcheroo module which is supposed to be located in /sys/kernel/debug on >2.6.35.

The problem is that when I boot my laptop, it freezes at a blackscreen unless I boot with options i915.nomodeset=0. It won't boot into X, but I can get to a terminal which is fine. But then vga_switcheroo isn't in /sys/kernel/debug.

Is this a ubuntu bug on how the kernel is compiled? Or is it because I have to boot with i915.nomodeset?

The livecd boots into X just fine, but I've never found a way to get X working on the installation. There's a lot of information about linux on the z12 but most of it is either outdated, doesn't work, or just plain doesn't make any sense

share|improve this question
add comment

3 Answers

up vote 1 down vote accepted

You need to have a kernel with vga_switcheroo enabled and KMS, i.e. kernel mode setting, active (which you haven't as you boot with nomodeset).

To check if vga_switcheroo is enabled in the kernel, have a look into the Ubuntu config of your kernel. You should find it in /boot with a name along the lines of /boot/config-2.6.35-XX-generic with XX some number corresponding to your kernel.

If it is not enabled, you find a custom Ubuntu kernel with vga_switcheroo enabled at http://www.ramoonus.nl/2010/08/linux-kernel-2-6-35-installation-guide-for-ubuntu-linux/

share|improve this answer
    
vga_switcheroo is enabled in the kernel, but it's still not in /sys/kernel/debug –  Falmarri Oct 7 '10 at 4:12
    
Kernel mode setting seems to be a requirement for vga_switcheroo to work. I edited my answer accordingly. –  fschmitt Oct 7 '10 at 7:55
add comment

I never got it working in Ubuntu, but I got a working KDE system using arch. So I'll post an answer here in case anyone else comes here for the same problem.

I could never get it working in Ubuntu. I couldn't boot without i915.modeset=0 and without that vgaswitcheroo doesn't show up.

What I ended up doing was installing arch, then before doing any setup in my new arch install, I installed a vanilla 2.6.35.7 kernel from kernel.org. That booted to a terminal just fine and I'm up and running on KDE.

share|improve this answer
    
The problem with Ubuntu might be with Grub 2. If you google for Ubuntu and your Laptop, you'll find reports that reverting Grub 0.97 allows booting with KMS enabled. I guess Arch still uses Grub 0.97? –  fschmitt Oct 9 '10 at 20:54
add comment

Problem may be in ubuntu patches to kernel. Try a vanilla kernel or another distro.

@fschmitt no it's not grub2, i'm using it on arch with KMS and vgaswitcheroo

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.