Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Currently, I opened my gnome terminal and the default charset is gb2312.

How can set the default charset to utf8 in Gnome terminal?

I checked the preference setting but seemed not to find it.

Thanks for any help!

share|improve this question

3 Answers 3

Start it with the desired charset.

env LANG=xx_XX.utf8 gnome-terminal
share|improve this answer
2  
This didn't work for me. –  Michael Mior Oct 16 '13 at 16:36
    
Nor me. And I tried all of "en_US.UTF-8", "en_US.utf-8", and "en_US.utf8" –  Edward Falk Nov 13 at 20:46

Simply right-click anywhere on the terminal and select Show Menubar and from the menu bar you select Terminal > Set Character Encoding > Unicode (UTF-8). At least this works using gnome-terminal 3.2.1.

share|improve this answer
1  
But it won't keep the change next time you opened it. –  xiaohan2012 Jan 2 '12 at 13:03
    
Ok, but what's the output of locale? I think you need to set the systems locale to an UTF-8 variant e.g en_US.UTF-8 in order to make it permanent. To list all enabled locales, run locale -a. To enable a locale, uncomment it in /etc/locale.gen and run locale-gen to update the list. –  Herman Torjussen Jan 2 '12 at 14:53
3  
My locale is en_US.UTF-8 but I'm still not getting UTF-8 encoding when I start gnome-terminal. –  Michael Mior Oct 16 '13 at 16:37

I found the answer buried in an Ubuntu forums thread (I'd asked a similar question here):

gconftool --set --type=string /apps/gnome-terminal/profiles/Default/encoding en_US.UTF-8

share|improve this answer
    
+1 tried all other solutions suggested here but this one did the trick. –  In-Ho Yi Dec 8 at 18:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.