Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed Slackware as a VM within Virtual Box. Host is Windows 7, if it matters. I have successfully installed guest additions and XFCE starts and runs cleanly with or without the guest additions. KDE however (which was set as the default for startx) starts well giving me the appropriate desktop at the appropriate resolution but crashes halfway during the splashscreen animation. I am not sure it is worth wrestling with it.

How do I change the default for startx to xfce? I realize that I can always start it at the command line with startxfce4 at the command line but I may like to change the inittab run level to 5 which would trigger KDE with it's crashes.

share|improve this question

3 Answers 3

As per man startx, the following files control the behaviour of startx:

   $(HOME)/.xinitrc         Client to run.  Typically a shell script which runs  many  programs  in  the
                            background.

   $(HOME)/.xserverrc       Server to run.  The default is X.

   /etc/X11/xinit/xinitrc   Client to run if the user has no .xinitrc file.

   /etc/X11/xinit/xserverrc Server to run if the user has no .xserverrc file.

So, if you want to keep using startx, you should adjust the contents of your .xinitrc file.

But this might not be necessary, since heavyweight desktop environments such as KDE often come with ready-to-use startup scripts. In the case of KDE, there is one called startkde (I don't remember whether it is used as a replacement for startx, or you have to place it in xinitrc).

share|improve this answer

Ensure ~/.xsession includes whatever it is that you want to start with startx. In this case:

echo startxfce4 >> ~/.xsession
share|improve this answer

Slack provides "xwmconfig" to perform these changes.

You run this as user or root.

However XServer crashing may still be an issue with another X setting and not XFCE's fault. Make sure as well the VM has enough video memory and settings allow easy deployment of the desktop (I use 28MB).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.