Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I first posted this on serverfault, but this forum seem to be more appropriate. http://serverfault.com/questions/345471/fedora-16-ssh-over-the-internet-home-network-help-same-computer-ok

I think I have set up the ssh servers on my home machine, but I don't know how to ssh into it from a client computer on the same network, let alone over the internet.

From the same server, I can do: ssh user@server

It has a static ip 192.168.1.100 which I have added to /etc/hosts. And everything is fine.

If I do so from the client in the same network, I can "ping host", but I can't ssh. It just stays stuck when I type "ssh server".

Also, how would I connect over the internet? I have a "name@dyndns.org" setup for the dynamic IP, but I wouldn't know how to ssh into that and then have it be routed to the 192.168.1.100 computer.

Appreciate any help!

Edit: The things I researched are already written (starting sshd service, editing /etc/hosts, pinging). I haven't been able to find any further info on google, as I'm not sure what I need to look for.

Edit2: This is the output from client of "ssh -vvv server". Thanks.

OpenSSH_5.6p1, OpenSSL 1.0.0e-fips 6 Sep 2011
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug2: ssh_connect: needpriv 0
debug1: Connecting to host [192.168.1.100] port 22.
debug1: Connection established.
debug3: Not a RSA1 key file /home/user/.ssh/id_rsa.
debug2: key_type_from_name: unknown key type '-----BEGIN'
debug3: key_read: missing keytype
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug3: key_read: missing whitespace
debug2: key_type_from_name: unknown key type '-----END'
debug3: key_read: missing keytype
debug1: identity file /home/user/.ssh/id_rsa type 1
debug1: identity file /home/user/.ssh/id_rsa-cert type -1
debug1: identity file /home/user/.ssh/id_dsa type -1
debug1: identity file /home/user/.ssh/id_dsa-cert type -1
share|improve this question
    
Run ssh -vvv host and copy-paste the output into your post. –  Gilles Dec 30 '11 at 23:30
    
@Gilles I think I need to add a key to my server from looking at the output of ssh -vvv host. The output is quite long from the host machine. Let me see if I'll head in the right direction by trying to add a key. –  chemelnucfin Dec 30 '11 at 23:41
    
@Gilles I pasted the output from the client machine. I'm still trying to see how to add the keys to the server machine (if that is indeed my problem). Thanks. –  chemelnucfin Dec 30 '11 at 23:57
    
This cannot be the full output. ssh still needs to try the password based auth. Please paste the complete output till you see the prompt. –  Aditya Patawari Dec 31 '11 at 5:56
    
@AdityaPatawari Hi Aditya, that is the full output. It hangs there. I need to Ctrl-C out of it. I'm thinking it may be a permission problem, but it doesn't seem like that right now. Any directions to look into will be appreciated. Thanks. –  chemelnucfin Dec 31 '11 at 7:03
show 7 more comments

2 Answers 2

Just try telnet to port 22 on the other host, if you are seeing OpenSSH server header then as such there is no problem with the server listening or client able to reach the opensshd server, but could be problem with ssh_config. If you are not able to telnet to port 22, then opensshd server is not reachable on the network. Possible reasons, network configuration, firewall rejections.

share|improve this answer
    
your ssh -vvv shows that sshd server is listening but the client is unable to establish the connection. Check your firewall settings. –  Nikhil Mulley Jan 5 '12 at 8:12
add comment

Fedora has a firewall enabled by default which block all ports. You just need to open up TCP Port 22 for OpenSSH in order to allow access from other computers.

http://www.techotopia.com/index.php/Basic_Fedora_Linux_Firewall_Configuration

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.