Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I attempt to login via ssh like so ssh marc_mtpt0@m3pt0.com I get this response:

/etc/ssh_config: line 51: Bad configuration option: UseDNS 
/etc/ssh_config: terminating, 1 bad configuration options lost connection

I've done this plenty in the past but it's no longer working properly. Not sure where to go from here or how to fix it. Any help is greatly appreciated. Thanks!

share|improve this question
add comment

2 Answers

Commenting out line 51 in the ssh_config file worked.

share|improve this answer
add comment

As the message says, UseDNS is not a valid option name in /etc/ssh_config. There is a server option called UseDNS; presumably you meant to put this line in /etc/sshd_config and edited the wrong file.

share|improve this answer
    
I actually have no idea how that line got into the ssh_config file at all because I've never edited these files before. Slightly confused at how it got in there. But it's all good now. Thanks so much! –  Marc Dec 30 '11 at 22:01
    
@Marc I recommend putting /etc under version control. I use etckeeper wherever it's available. –  Gilles Dec 30 '11 at 22:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.