Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

About a month ago I installed Lubuntu 11.10. Since that time there is a problem with booting and shutting down.

  1. Booting is endless. This screen never disappears, so I have to manually press the shutdown button of my laptop
  2. I turn the laptop on and have the possibility of choice. I choose the second option - Linux 3.0.0-14-generic (recovery mode)
  3. I will choose resume normal boot option
  4. Success

Sometimes Lubuntu boots normally but in most cases I have to go through steps 1-4. When I shutdown the OS I will see this screen forever, so I have to press my laptop button to turn it off.

Do you know where is the problem and how to solve it? I'm asking rather here (not in Ubuntu), because this is system problem what I'm interested in (not the matter of one distribution) but booting process and here are more experts interested in the system (what is under the hood).

thank you

share|improve this question
1  
Some (most?) shutdown screens can be stopped by pressing escape. Then you can see what userspace and the kernel say during shutdown. That may give you hints. –  Folkert van Heusden Dec 30 '11 at 10:41

1 Answer 1

For some reason, I cannot comment on the question, so I am forced to write it here. My apologies.

Edit /etc/default/grub and check GRUB_CMDLINE_LINUX_DEFAULT, there is probably some 'quiet' and 'splash' options there. Remove them, run 'sudo update-grub' and reboot. You should now see some more information during the boot process, and maybe a hint what's going wrong.

share|improve this answer
    
I appreciate every answer. After reboot, grup command line appears and I have to type manually –  xralf Dec 30 '11 at 12:58
    
You probably did it wrong :) There should be no need for manually specifying what to boot. Anyway, are you seeing any error messages during boot? –  Patrick Dec 30 '11 at 14:23
    
I just comment the line in /etc/default/grub. During boot I haven't catched nothing, only when shutting down, but it's too fast to make a photo. It would be best to redirect the messages to a file, if it's possible. –  xralf Dec 30 '11 at 14:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.