Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have never noticed this behaviour before, and am a little confused as to what is happening. I have a local copy of firefox running, then ssh (ssh -X <url>) into a remote server and start a copy there to use the local display. Turns out the local firefox just opened a new window. I verified with ps x|grep firefox that indeed no firefox process is started on the remote server.

This same strange behaviour happens in reverse: if I have a remote firefox running and try to start a local one, then the remote one opens a new window.

I am on ubuntu 10.4, with a nearly completely fresh install (I just got this computer this afternoon). I was trying to have the two firefoxes running at the same time so that I could easily run down the list of plugins to install.

What is happening here, and how can I avoid it from happening?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

If I had to make an educated guess about what's going on here, I'd say that firefox first looks for an open firefox window before launching, and if that exists sends it a message using X to just start a new browser window. Because the remote system is using your local display, whatever it uses for detection is picking up the local window. (This would also explain why the remote window is found when you're starting a local firefox process.)

You can test this by closing all local firefox windows, and then trying to start firefox on the remote server - if the detection is happening like I think it is, there won't be any running windows for it to latch on to, so it'll start an instance on the remote system like you expect.

As far as actually fixing the issue, tante's suggestion to set MOZ_NO_REMOTE is the proper solution.

share|improve this answer
    
The test certainly comes out positive; I never knew there was such a messaging system in X. –  kasterma Oct 8 '10 at 15:58
add comment

Has been an issue with firefox for quite a while, try running firefox as firefox -no-remote (setting MOZ_NO_REMOTE=1 as environment variable should work as well).

Here's more info

share|improve this answer
1  
Thanks, that solves the problem. I also found some info in mozillazine: kb.mozillazine.org/… One thing that it does not solve is my confusion: I am on computer A, I ssh over to computer B. On computer B I start a new firefox to use the display on computer A, how does computer B know not to start a new process? This must be a part of the X protocol I am not familiar with. –  kasterma Oct 6 '10 at 0:57
    
In sshd_conf you have an option for that: X11Forwarding yes This tells ssh to ask X to forward it's output over the ssh tunnel to your X server whenever you start an application with GUI. –  Patkos Csaba Oct 8 '10 at 6:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.