Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have an Intel graphics card, of which I can't tell whether or not it's being recognized. When I go through GUI to the System Info section, it states that my graphics card is unknown. Despite this, my lspci displays the graphics card perfectly fine.

Question

Is there any way to get OpenGL working correctly on Ubuntu 11.10, or, if this isn't possible (due to my graphics card), would there be any other distros recommended as far as getting this work?

lspci

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b4)
00:1d.0 USB Controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe (rev 10)
02:00.1 SD Host controller: Broadcom Corporation NetXtreme BCM57765 Memory Card Reader (rev 10)
02:00.2 System peripheral: Broadcom Corporation Device 16be (rev 10)
02:00.3 System peripheral: Broadcom Corporation Device 16bf (rev 10)
03:00.0 Network controller: Intel Corporation Centrino Advanced-N 6205 (rev 34)
share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

Just because system settings doesn't correctly report your graphics card, doesn't mean it's operating incorrectly. I'm not sure what you mean by 'Getting OpenGL to work', but I'm guessing you mean Verifying accelerated OpenGL?

The two major components of basic acceleration are Xv, and GLX Direct Rendering. Xv does Hardware Video Overlay, and GLX Direct Rendering does OpenGL via Graphics Hardware.

Use glxinfo to check for GLX Direct Rendering, glxinfo is installed via

sudo apt-get install  mesa-utils

Run this command to get your direct rendering status, it will be a yes or no answer.

glxinfo  | grep rendering

Use xvinfo to check for Video Overlay. Make sure x11-utils package is installed.

sudo apt-get install x11-utils

Run this command to check for Video Overlay, should be a long listing, not an error.

xvinfo

This is just the basics, it doesn't verify the new HD video extensions. It should however, tell you if acceleration is even working.

share|improve this answer
    
Worked like a charm. Thank you. –  Holland Dec 30 '11 at 7:17
1  
Your Welcome! Glad I actually helped. –  TechZilla Dec 31 '11 at 3:06
add comment

According to the official Intel Linux Graphics Drivers website Linux should support Intel® HD Graphics P3000 included in the Intel C200 Series Chipset Family out of the box.

The cause of your problem is according to the information provided by Intel that Intel® HD Graphics P3000 is only available with select Intel Xeon processor E3-1200 SKUs. So please check up with Intel, whether your specific system is actually OpenGL-capable. I can't answer that question from the sparse information provided by lspci.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.