Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to disable scrolling through command history for the Xfce terminal? I don't wish to rely on palm rejection, I'd just like it disabled when I'm using the terminal. Specifically I'm talking about not cycling through previous commands at the prompt when scrolling with mouse/touchpad.

share|improve this question
up vote 2 down vote accepted

You are describing the feature of VTE (used in XFCE Terminal) which translates wheel-mouse scrolling into up/down cursor-keys when using the alternate-screen. That happens if you are running screen in something like xterm. You can avoid that by preventing screen from using the terminal's alternate screen feature.

For example (see How to disable alternate buffer in GNU screen itself but not for vim, less inside it?), tell screen that the feature does not exist (by putting this in .screenrc):

termcapinfo xterm ti@:te@

A similar workaround is used for tmux (see Properly disable terminal capabilities for alternate screen in tmux), putting this in .tmux.conf:

set -ga terminal-overrides ',xterm*:smcup@:rmcup@'

This translation of scrolling behavior does not appear to be configurable in VTE-based terminals. It is configurable in xterm, e.g., alternateScroll (patch #282).

Further reading:

share|improve this answer
    
I use TMUX, does that command work with it too? – pepper_chico Apr 24 at 15:48
    
It's the same problem - different details for solution (will see...) – Thomas Dickey Apr 24 at 15:49
    
I'm using ArchLinux, I find it strange that I didn't find termcapinfo with pacman/yaourt, will take a look whether it's part of other named package or a related tool. – pepper_chico Apr 24 at 15:51
    
It is the name of a setting in .screenrc (configuration for screen). – Thomas Dickey Apr 24 at 15:55
    
I've put set -ga terminal-overrides ',xterm*:smcup@:rmcup@' on my .tmux.conf and reloaded, it didn't work through reloading, so I imagined of course that I needed to restart the tmux process, it worked like a charm, many thanks. – pepper_chico Apr 24 at 15:59

In the Edit > Preferences menu of xfce4-terminal you can disable the scrollbar.

If you set the scrollback value to 1, it will disable scrolling back using the scroll wheel on your mouse.

I'm using xfce4-terminal 0.6.3, the default version for Ubuntu 14.04.

share|improve this answer
    
My particular issue isn't scrolling the window, but cycling through previous commands, I don't wish this to happen through mouse/touchpad, when I scroll, it's not the window that scrolls, but instead, cycling commands at the prompt. – pepper_chico Apr 24 at 15:24
    
After applying the accepted answer, I also need this one to avoid scrooling now. Thanks. – pepper_chico Apr 24 at 16:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.