Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm using the i3 Window Manager, and am quite happy so far, but I have a few issues.

  1. Using XFCE, my "Desktop" is seen as a separate container (window). That means that when I open a new program in the first workspace, that it will split the screen in two and show Desktop as one window, and the other program in another window. I can minimize the size of the desktop, or use the 'tabbed' option to minimize impact, but this is all not convenient. I want i3 not to treat the Desktop as a Window, at all. If that means 'losing' my Desktop, no problem. I tried 'closing' this window, but my whole session is closed and I return to the initial login screen.

  2. There are notification windows from Thunderbird that should float but they appear as new windows instead. I tried adding for_window [class="xfce4-notifyd"] floating enable to my config file, but this does not work.

  3. How can I shutdown with a keybinding? I tried bindsym $mod+x exec shutdown and bindsym $mod+x exec /home/user/shutdown.sh (which has sudo shutdown -Ph now), but none of them work.

I am using Arch Linux.

share|improve this question
add comment

4 Answers

up vote 1 down vote accepted
  1. Have you done anything to not start xfwm4? Generally, see the Haskell wiki's notes on using XFCE4 with XMonad, as they probably help you with i3, too.
  2. Here's a mailing list thread on this issue (no proper solutions, tough).
  3. see i3's userguide on keybindings, something like bindsym mod+x exec xfce4-session-logout should be ok (xfce4-session-logout is referred to in the first link).
share|improve this answer
    
Thanks for the replies. I do not start xfwm4, in fact. Have ultimately solved the other issues by removing XFCE completely and running the computer without a Desktop environment. –  user11780 Jan 9 '12 at 14:53
add comment

2. I had the same issue and found this page. It's a little typo in the class name: Xfce4-notifyd. I used xprop to get the right class.

Now I am usingfor_window [class="Xfce4-notifyd"] floating enable; border none; focus mode_toggle.

Reading the mailing list thread a solution is to change the notifyd to libnotify-bin (debian) or notify-osd (ubuntu), maybe one of those is available for arch.

share|improve this answer
    
Note that this doesn't seem to be required with i3 version 4.8, but I had to use it for version 4.7.2. –  TimP Jun 24 at 23:19
add comment

You can get rid of the desktop container by creating a symlink from /usr/local/bin/xfdesktop to /bin/true. Then either log in and log out or just killall xfdesktop. Note that if you do this, you will break regular Xfce for all users. If you want to avoid this, you'll have to place the symlink somewhere specific to your own PATH.

share|improve this answer
add comment

I have a setup that prevents xfdesktop from launching, so there's no desktop in the i3 session at all, which should workaround your problem. In XFCE you can save multiple sessions. Create two sessions (XFCE and I3) and create an autostart i3 script. In the XFCE session, xfwm4 and xfdesktop are launched; in the i3 session only i3 is launched.

The XFCE session:

YTT6G.png

and the i3 session with the XFCE panel:

n9A2s.png

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.