Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just tried to install oh-my-zsh. I get the following error when I try to run rvm:

zsh: command not found: rvm

I also get the following error when I try to open a new tab:

/Users/jack/.zshrc:source:34: no such file or directory: /Users/jack/.oh-my-zsh/oh-my-zsh.sh
/Users/jack/.zshrc:source:38: no such file or directory: .bashrc

Here's my .zshrc file:

# Path to your oh-my-zsh configuration.

# Set name of the theme to load.
# Look in ~/.oh-my-zsh/themes/
# Optionally, if you set this to "random", it'll load a random theme each
# time that oh-my-zsh is loaded.

# Example aliases
# alias zshconfig="mate ~/.zshrc"
# alias ohmyzsh="mate ~/.oh-my-zsh"

# Set to this to use case-sensitive completion

# Comment this out to disable weekly auto-update checks

# Uncomment following line if you want to disable colors in ls

# Uncomment following line if you want to disable autosetting terminal title.

# Uncomment following line if you want red dots to be displayed while waiting for completion

# Which plugins would you like to load? (plugins can be found in ~/.oh-my-zsh/plugins/*)
# Custom plugins may be added to ~/.oh-my-zsh/custom/plugins/
# Example format: plugins=(rails git textmate ruby lighthouse)
plugins=(git bundler brew gem rvm cscairns)

source $ZSH/oh-my-zsh.sh

# Customize to your needs...

source .bashrc
export PATH=/usr/local/bin:$PATH

What do I need to do to fix these errors?

share|improve this question

For this:

/Users/jack/.zshrc:source:34: no such file or directory: /Users/jack/.oh-my-zsh/oh-my-zsh.sh

The problem is this line:

source $ZSH/oh-my-zsh.sh

You don't have a file called oh-my-zsh.sh in /Users/jack/.oh-my-zsh

For this:

/Users/jack/.zshrc:source:38: no such file or directory: .bashrc

The problem is the same as above; essentially, you don't have .bashrc file in /Users/jack/

Your $ZSH is pointing to /Users/jack/.oh-my-zsh and it looks like there's no such file in that directory with the name zsh.sh

As far as the initial problem (zsh: command not found: rvm) the issue is that the command rvm is not located anywhere in your $PATH which apparently points to /usr/local/bin plus whatever the system-wide setting is.

I recommend you use find / -name "rvm" and see where in the file system is rvm really located and then update your $PATH variable as so: export PATH=/path/to/rv/:$PATH

share|improve this answer

Put the below line to your ~/.zshrc file to fix the error with rvm

[[ -s "$HOME/.rvm/scripts/rvm" ]] && source "$HOME/.rvm/scripts/rvm"
share|improve this answer

I had the following error:

/Users/frankus/.zshrc:source:50: no such file or directory:  /Users/frankus/.oh-my-zsh^M/oh-my-zsh.sh

I fixed it by renaming the oh-my-zsh folder

mv ~/.oh-my-zsh^M ~/.oh-my-zsh
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.