Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have just installed i3 as a Window Manager, and I feel the keyboard shortcuts and the integrated status bar are sufficient to manage my open applications, view the time, etc. In other words, I'd like to disable the Applications Menu that comes with XFCE. How should I do this?

Under SETTINGS > PANEL I can remove all panels except for the principal one (Panel 1), which holds the Applications Menu, clock etc. I can only remove all elements inside, or put it on show/hide, but I do not see a way to permanently remove this. How can this be achieved?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

$ pkill xfce4-panel Done !

In order to save it, you should save your session at the log out.

And i just found that on the XFCE wiki:

How do I disable the taskbar in Xfce 4.2?

Just don't run it at startup…

  • If you use the session manager, kill the taskbar, save your session
    on logout, and the taskbar will be gone when you'll log back in.

  • If you don't use the session manager, comment out the xftaskbar4 line in your $sysconfdir/xdg/xfce4/xinitrc or ~/.config/xfce4/xinitrc.

  • If you use the session manager and want to remove the taskbar system-wide, comment out the taskbar line in the $sysconfdir/xgd/xfce4-session/xfce4-session.rc file.

P.S , the sysconfdir is /etc/xdg/..... in my distro (Arch), but i think that it is on every distro.

Another solution would be (if you are using some variant of Ubuntu), to add to your ~/.config/xfce4/autostart.sh the following:

if [ "$(pidof xfce4-panel)" ]; then
    killall xfce4-panel &
fi
share|improve this answer
    
thanks, that does enable me to kill it while in a session, but the config files referenced here do not exist in XFCE 4.8 (they appear to be 4.2-specific). I do not use sessions and would like to disable this on startup. Any idea if this is possible? Tried Googling for this but to no avail... –  user11780 Dec 27 '11 at 21:50
    
@plua: I have added to the Answer, the sysconfig directory is actually under /etc/xdg/ –  Hanan N. Dec 27 '11 at 22:13
    
Thanks, I'm also using Arch, and found the directory at the path you provided. But there is no "xftaskbar" line in the xinitrc config file there (in fact, there is no xftaskbar in any of the xinitrc files I found on my system). It looks like this line existed in 4.2, but in 4.8 this appears to be different. I can not find where the taskbar (or xfce4-panel) is actually being initiated, although it does exist on every startup. I guess I will kill this process after startup. If you have any tips, be sure to let me know! –  user11780 Dec 27 '11 at 23:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.