Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I start vim in a screen session, and activate the mouse:

:set mouse=a

the mouse remains disabled. I cannot switch tabs via mouse click.

How can I configure screen so that mouse support in vim works?


Edit:
I guess the version of my screen is too old. When I upgrade it, mouse works fine in vim.

I still want to know how to focus different regions(Ctrl-a S) via mouse click.

share|improve this question
1  
Does mouse support works outside screen? I didn't have to change any settings. –  phunehehe Dec 27 '11 at 12:05
    
@phunehehe mouse works fine when :set mouse=a outside of screen –  kev Dec 27 '11 at 12:06
    
@kev Post your .screenrc. Something in it and/or related to it, $TERM, is interfering with vim. –  nicerobot Dec 27 '11 at 14:48
    
@nicerobot I don't have a .screenrc. –  kev Dec 27 '11 at 14:58
1  
@kev Doesn't that kinda defeat the purpose of using screen? I mean, the main reason to use something like screen versus GUI terminals is to keep your hands on the keyboard constantly. If you're going to be using the mouse, just use a GUI terminal that supports tiling of its windows. Honestly, i can switch between regions far faster with the keyboard than i can by reaching for the mouse. –  nicerobot Dec 27 '11 at 15:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.