Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running OpenSuSE 12.1 with the KDE desktop on a test machine. The "logout" menu entry in the KDE menu does not seem to do anything. I am not aware of changing any KDE settings that might be relevant.

How can I find out the cause of this behaviour, and how can I remedy it?

share|improve this question
    
try running kbuildsycoca4 --noincremental –  harish.venkat Dec 26 '11 at 5:10
    
Thanks for the suggestion. This did, however, not change the situation. –  jstarek Dec 26 '11 at 13:02
    
i have a hard time imagining what you are actually talking about. can you include a screen shot, or describe a bit more? –  ixtmixilix Feb 13 '12 at 17:58
    
It's simple: Clicking on the "logout" menu entry does not do anything except dismiss the launcher. There are no processes started, no log entries, nothing. I am both asking for ways how to diagnose this (I imagine there might be a way to make KDE's event handlers write more verbose info to the logs or something similar) and how to remedy the problem. –  jstarek Feb 13 '12 at 19:46
add comment

2 Answers

up vote 1 down vote accepted

Apparently, this is a bug KDE knows about and seems to be quite common. It seems that it could be caused by KDE trying to play the "logoff" sound byte and hanging there.

The only solution I could find was to disable the audio (through the configuration menu) and try again.

share|improve this answer
    
Interesting... I'm on a server without configured sound system, so I'll check if thtat's related. –  jstarek Feb 13 '12 at 19:47
    
I don't know what I did wrong when I initially tested this, but testing again today, disabling the sound system solved the issue! Thanks for pointing that out. –  jstarek Apr 25 '12 at 18:04
    
Good to hear you got it fixed @jstarek, and that's for remembering this question. –  MaxMackie Apr 25 '12 at 19:57
add comment

I had similar problem after update to OpenSuSE 12.1 . The cause of this problem was a slight change to the shutdown / reboot commands.

Look at the file /usr/share/kde4/config/kdm/kdmrc . Find [Shutdown] section, comment any HaltCmd = or RebootCmd = . This properties could contain old syntax for shutdown/reboot commands.

share|improve this answer
    
Thanks for your hint, but those values were already commented out in my kdmrc. Also, setting them to valid values manually did not change anything. –  jstarek Apr 25 '12 at 18:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.