Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I started my ubuntu today and Audio card was not working. Card is not even listed with lshw. No device with description like physical id: 1b (I remember the old device settings).

Any ideas?

share|improve this question
did you update/install/change anything recently? – Stefan Oct 5 '10 at 9:56
No update recently – amra Oct 5 '10 at 10:20
what is the output when you lsmod|grep '^snd' | column -t or ls -l /sys/module/snd/holders ? – Stefan Oct 5 '10 at 10:33
Might it simply have slipped out of its socket? – fschmitt Oct 5 '10 at 10:36
@Stefan ls -l /sys/module/snd/holders result: ls: cannot access /sys/module/snd/holders: No such file or directory – amra Oct 5 '10 at 10:51
up vote 4 down vote accepted

This can be caused by any number of things, you should take a look at the Comprehensive Sound Problem Solutions Guide on the Ubuntu Forums

Exerpt from the Guide:

(2) Type this into the shell: Code:

lspci -v

Success - At this point, you should see your sound card listed. This is a positive sign because it means that Ubuntu is detecting the presence of your soundcard, but the drivers are not installed/running. Leave your shell running since you will need it.

Failure - If it is not listed, then there are a few things that you can do.

  • If your soundcard is an onboard sound card, then it might be disabled in the system's BIOS. You will have to reboot and hit the key that lets you enter into the BIOS (usually Delete, F2, or F.

  • If your soundcard is not onboard, make sure that it is properly seated in the PCI slot. If your card is working under Windows then this is not a problem.

share|improve this answer
lspci doesn't list audio card. I checked BIOS and it's enables. I think this is final stage :o( – amra Oct 5 '10 at 11:25
did you try re-installing all the drivers? – Stefan Oct 5 '10 at 11:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.