Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My device is a Motorola Atrix 4G (ME860). It has an 11G internal SD card, and I inserted a new 16G SD card into the SD Card slot.

When I connect the phone to my computer with a USB cable, it shows two removable disks on my computer system, on Windows.

But on Linux (my Gentoo box), it shows only one device (/dev/sdc - the internal 11G SD card). I can't see the other 16G SD card device.

How can I mount the external SD card on Linux?

dmesg info:

<7>[ 1136.355862] hub 1-1:1.0: state 7 ports 6 chg 0000 evt 0002
<7>[ 1136.356126] hub 1-1:1.0: port 1, status 0101, change 0001, 12 Mb/s
<7>[ 1136.459809] hub 1-1:1.0: debounce: port 1: total 100ms stable 100ms status 0x101
<6>[ 1136.532634] usb 1-1.1: new high speed USB device number 12 using ehci_hcd
<7>[ 1136.625519] usb 1-1.1: default language 0x0409
<7>[ 1136.634493] usb 1-1.1: adding 1-1.1:1.0 (config #1, interface 0)
<7>[ 1136.636506] usb-storage 1-1.1:1.0: usb_probe_interface
<7>[ 1136.636527] usb-storage 1-1.1:1.0: usb_probe_interface - got id
<6>[ 1136.636661] scsi13 : usb-storage 1-1.1:1.0
<7>[ 1136.636788] usb 1-1.1: adding 1-1.1:1.1 (config #1, interface 1)
<5>[ 1137.642196] sd 13:0:0:0: [sdc] Attached SCSI removable disk
<3>[ 1140.358324] sd 13:0:0:0: [sdc] No Caching mode page present
<3>[ 1140.358333] sd 13:0:0:0: [sdc] Assuming drive cache: write through
<3>[ 1140.363312] sd 13:0:0:0: [sdc] No Caching mode page present
<3>[ 1140.363321] sd 13:0:0:0: [sdc] Assuming drive cache: write through
<6>[ 1140.367887]  sdc:
share|improve this question
    
What does dmesg(1) report when plugging it in? –  sarnold Dec 22 '11 at 5:27
    
I add dmesg output, any useful info ? –  Peng Liang Dec 22 '11 at 5:38
1  
I already fix this problem. I didn't set CONFIG_SCSI_MULTI_LUN in .config when compiling kernel. –  Peng Liang Dec 22 '11 at 7:06
2  
@PengLiang Please post this as an answer and accept it, so that when someone else has this problem, they'd find your solution easily. –  rozcietrzewiacz Dec 22 '11 at 15:23
add comment

migrated from stackoverflow.com Dec 22 '11 at 5:07

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 1 down vote accepted

I found out how to fix this problem: I hadn't set the CONFIG_SCSI_MULTI_LUN option in my .config when configuring my kernel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.