Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

Why can I see AAAA DNS requests when I run tcpdump on my Scientific Linux PC when I haven't got any IPv6 addresses? I already rebooted after setting NETWORKING_IPV6=no in /etc/sysconfig/network and options ipv6 disable=1 in /etc/modprobe.d/ipv6.conf, but I can still see AAAA requests if I visit a few websites. How can I disable the requesting of AAAA records?

share|improve this question
    
options ipv6 off and then in super shell run modprobe -r ipv6 –  Nikhil Mulley Dec 21 '11 at 6:18
2  
If you have an IPv4 address, you automatically have a 6to4 IPv6 address, through which you may be able to reach IPv6 hosts (depending on what IPv6 connectivity your ISP offers). –  Gilles Dec 21 '11 at 23:42
    
Have you removed ::1 and other ipv6 addresses from your /etc/hosts? –  Marcin Dec 22 '11 at 15:16
    
Firefox has additionally the option to disable IPV6: go to about:config then change network.dns.disableIPv6 –  jofel Jul 19 '12 at 14:46

2 Answers 2

Check if file /etc/resolv.conf has "options inet6". If so, that line should be removed using your favorite editor (invoked via sudo or as root, after making a backup copy). If you are using DHCP, it may get put back in the next time you reboot even if you have no IPv6 in your kernel network stack.

share|improve this answer

Try to pass the following option to the kernel, on the Grub stage:

modprobe.blacklist=modname1

Where modname is the module name of ipv6 on Scientific Linux (probably ipv6)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.