Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When opening a new tab in gVim (with :tabe), the status line at the bottom of the screen disappears. If I press : and start typing a command I can no longer see the command on the status line.

When the gVim window is maximized, opening a tab pushes the status line below the screen. When the gVim window is not maximized, the window will increase in height. This problem happens in Gnome and in Xmonad.

I'm looking for a way to get around this issue. Is there a way to force the window to redraw such that the status line fits inside the window?

share|improve this question
    
This behaviour happens to me as well, using gVim 7.3 and KDE 4.4+. I've tried three different fixes for it: 1) Patch, recompile: paskov.biz/blog/… 2) Screw with KDE's "Application Specific" settings. This sorta-kinda-works, but isn't reliable. 3) Switch to Qtk-gVim. This doesn't really fix it either, although it does maximize properly. The problem is highly frustrating, even if de-maximize+maximize fixes it. –  Wesley Burr Feb 3 '12 at 20:44
add comment

3 Answers 3

up vote 1 down vote accepted

This happens to me as well. The workaround that I use is to minimize gVim then maximize it again. After that the status bar is visible again.
Bug is described here: https://bugs.launchpad.net/ubuntu/+source/vim/+bug/137854
Bug is reported fixed in debian, but the issue is still there with Ubuntu 11.04 (Natty)

share|improve this answer
    
I use the same workaround to resolve the bug. Thanks for the bug link. –  Trey Hunner Dec 20 '11 at 16:23
add comment

The problem only seems to come up when the tab line first gets displayed. The workaround I use is just to always show the tabline:

:set showtabline=2

(in .vimrc of course). I personally don't mind having the extra line there when I just have one tab open, so it works for me, anyway.

share|improve this answer
add comment

I upgraded to Vim 7.3, using the Vim 7.3 PPA for Ubuntu mentioned here. Unfortunately this still did not solve the problem.

My current workaround involves using no-gui tab pages instead. I removed the GUI tab pages by removing e from guioptions in my .vimrc file, like so:

set guioptions-=e
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.