Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

You can change layouts in Xmonad with mod+space or switch windows (in fullscreen) with mod+tab.

I encounter everyday the problem that these bindings stop working (I don't know what causes it). I'm able to change workspaces with mod+1 | 2 | ... | 9 and this problem occurs usually only in one workspace. I tried to solve it with moving all the windows from the workspace (where it stopped working) to another workspace but this didn't help. I solve it with logging out and logging in. Is there some way to solve it without logging out?

share|improve this question
    
Did you try reloading xmonad without logging out, with <kbd>mod+Q</kbd>? Does the problem persist if you do this? –  Dalker Dec 19 '11 at 11:50
    
Also, if the problem persists, it might help if you posted your xmonad.hs which might help determine its cause. –  Dalker Dec 19 '11 at 12:04
    
@Dalker I can try it as soon as this problem occurs again, but it's not the best solution because after reloading some applications defined in xmonad.hs automatically launch. –  xralf Dec 19 '11 at 13:07

2 Answers 2

up vote 4 down vote accepted

It could be you mod+left mouse button draged a window in master -- this will float the window and cause the symptoms you described. (The layout actually changes, behind the window.)
mod+t should unfloat the window.

share|improve this answer
    
Maybe I exaggerated that this occurs every day (but there are times it happens twice a day, it depends on what I'm doing and intensity of work). I'm waiting for it since I asked this question. When it will happen I will try your advice. –  xralf Dec 20 '11 at 11:05
    
Actually, you can test if the problem is what I described. Just press mod and mouse-drag a window, see if this is the issue. –  sr_ Dec 20 '11 at 13:43
    
Yes, this caused the same problem and <kbd>mod+t</kbd> solved it. However, I'm not sure if I was dragging windows before. It's possible that in my case this happened another way. I will accept it, but when <kbd>mod+t</kbd> won't solve it, I will reopen. –  xralf Dec 20 '11 at 14:13
    
Now, I can confirm that your solution works (I wasn't dragging anothing) and mod+t helped again. –  xralf Dec 20 '11 at 21:08
    
Something akin to float in your xmonad.hs, maybe? –  sr_ Dec 20 '11 at 21:18

Another possibility is that you've pressed mod-comma or mod-period and changed the number of windows in the master pane. The default is to have one window in the master pane. If you then press mod-period, you reduce that to zero, which would essentially change Tall mode to Wide mode when there are only two windows open. You can also get into a similar situation if you press mod-comma and increase the number of windows in the master pane up to the number of windows being displayed. This setting is remembered per-workspace and per-layout on that workspace.

To reset the layout to the default configuration for a given workspace, you can press mod-shift-space.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.